Engine dies after braking
Results 1 to 6 of 6

This is a discussion on Engine dies after braking within the General Maintenance, Troubleshooting & Accidents. forums, part of the Tech & Modifying & General Repairs category; Hey everyone, I'm a noob and I'm from Australia, so if I don't make sense, just blame it on the ...

  1. #1
    Registered User
    Join Date
    Jun 2007
    Location
    Perth, Western Australia
    Posts
    3

    Post Engine dies after braking

    Hey everyone, I'm a noob and I'm from Australia, so if I don't make sense, just blame it on the fact that I'm living upside down k??

    Anyway, I've got a 2000 WRX and since yesterday I've been having this issue. The car starts fine and idles normally. It drive fine, still feels the same amount of power and everything, but when I brake and come to a complete stop, say at traffic lights or whatever, the rpm drops down to almost 0 and the car has stalled a few times as well.
    This happens when in neutral or when on the clutch. If the engine doesn't die, the rpm picks up after a second and goes back to idling normally.

    I have next to no mods. Turbo timer, exhaust and air filter. That's it.

    Any ideas or suggestions about what to do? I've tried resetting the ECU but that didn't help. Well it did for about 5 minutes then it started happening again.

    Thanks guys

  2. Remove Advertisements
    ClubWRX.net
    Advertisements
     

  3. #2
    Registered User rr1911's Avatar
    Join Date
    Nov 2005
    Location
    Central Florida
    Posts
    0
    clogged injector, battery going dead, bad fuel, ecu going ,turbo timer going , battery fluid leavel, fuel filter clogged
    is the ac on when this is happening ? or is with the ac off too ?
    Army Ranger For Life ! Thin Blue Line
    Military Militia # 1911/ Blobeye Syndicate # 1911/ Modifier's Anonymous # 1911/ Hawk-Eye Alliance # 1911
    All We'll Drive
    DIFFERENT STROKES
    EVEN MY DENTIST TOLD ME FLOSS 7 DAYS A WEEK
    POST WH0RE KING

  4. #3
    Registered User
    Join Date
    Jun 2007
    Location
    Perth, Western Australia
    Posts
    3
    This happens with the ac off and on.
    I haven't checked the battery. The ECU is fine I think, I did the full reset procedure as outlined on this website.
    The turbo timer is off and I only use 98 RON premium unleaded fuel. It's only been 6 months since last service...it's going in on Monday so hopefully they can change the filters and get it sorted.

    Thanks for your reply tho mate, will check out the battery

  5. #4
    Registered User rr1911's Avatar
    Join Date
    Nov 2005
    Location
    Central Florida
    Posts
    0
    let me know what happens bro..

    might be the fuel filter, battery or water in the gas
    good luck
    Army Ranger For Life ! Thin Blue Line
    Military Militia # 1911/ Blobeye Syndicate # 1911/ Modifier's Anonymous # 1911/ Hawk-Eye Alliance # 1911
    All We'll Drive
    DIFFERENT STROKES
    EVEN MY DENTIST TOLD ME FLOSS 7 DAYS A WEEK
    POST WH0RE KING

  6. #5
    Moderator YBNormal07's Avatar
    Join Date
    Jul 2003
    Location
    PA
    Posts
    6,244
    I Support ClubWRX
    Sounds like the Idle Air Control. Have you check for any CELs yet?

    Here is a good thread on Nasioc for cleaning/repairing the IAC.

    http://forums.nasioc.com/forums/showthread.php?t=781242
    tEh PriUs=teH faSTah!@@!
    08 Audi S5 Black Diamond edition
    SOLD: 05 SWP Legacy GT Limited 5MT, 13.3ish@105 (stage 2) crappy stock clutch
    SOLD: 04 MPS/SW WRX Sti. 12.971 @ 103.97 (stock)
    278 AWHP/283 AWT, Catback exhaust
    306 AWHP/341 AWT, Stage 2
    (Scott) Moderator-STi, Drag Racing, Car Purchasing, and Tutorial Forums

  7. #6
    Registered User dcpatters's Avatar
    Join Date
    Sep 2004
    Location
    Irvine, CA
    Posts
    1,174
    ^^^^

    I was just going to suggest that. Even read the thread about it yesterday.
    2008 Evo X GSR. Custom tuned, Works panel filter, Intercooler pipe upgrade, TBE.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •