check engine light in stop and go traffic
Results 1 to 4 of 4

This is a discussion on check engine light in stop and go traffic within the General Maintenance, Troubleshooting & Accidents. forums, part of the Tech & Modifying & General Repairs category; my check engine light has been recently turning on when i'm in stop and go traffic, and my 03 wrx ...

  1. #1
    Registered User
    Join Date
    Jun 2007
    Posts
    1

    check engine light in stop and go traffic

    my check engine light has been recently turning on when i'm in stop and go traffic, and my 03 wrx starts to idle high (usually around 2-3 rpm but sometimes near 4) if i get on the highway and drive around 80 or so for a while, the car calms down a bit, and when idling drops down to around 1.5-2. this happens nearly every time i hit traffic, or are in a lot of stop and go movement. the light usually goes out within the next day or two, but then comes back on next time im in traffic. anyone got any ideas on what the problem is? i dont want to take it to a shop yet because im low on money and i want to know what im getting in to before i drop it off. thanks for anyones ideas

  2. Remove Advertisements
    ClubWRX.net
    Advertisements
     

  3. #2
    Registered User rr1911's Avatar
    Join Date
    Nov 2005
    Location
    Central Florida
    Posts
    0
    the cable is sticking
    Army Ranger For Life ! Thin Blue Line
    Military Militia # 1911/ Blobeye Syndicate # 1911/ Modifier's Anonymous # 1911/ Hawk-Eye Alliance # 1911
    All We'll Drive
    DIFFERENT STROKES
    EVEN MY DENTIST TOLD ME FLOSS 7 DAYS A WEEK
    POST WH0RE KING

  4. #3
    Registered User Micah's Avatar
    Join Date
    Oct 2005
    Location
    Ocean Grove, NJ
    Posts
    4,142
    Quote Originally Posted by rismr View Post
    my check engine light has been recently turning on when i'm in stop and go traffic, and my 03 wrx starts to idle high (usually around 2-3 rpm but sometimes near 4) if i get on the highway and drive around 80 or so for a while, the car calms down a bit, and when idling drops down to around 1.5-2. this happens nearly every time i hit traffic, or are in a lot of stop and go movement. the light usually goes out within the next day or two, but then comes back on next time im in traffic. anyone got any ideas on what the problem is? i dont want to take it to a shop yet because im low on money and i want to know what im getting in to before i drop it off. thanks for anyones ideas
    Any AutoZone will read the code for free. I believe many autoparts chains have the same policy. If not, just go to Walmart and buy a code reader, use it in the parking lot, then walk back in and return it. I refuse to drive around with a CEL. Once it's lit for one issue, you'll never know if it's lit for another without checking the codes.
    Torch Red 2002 Chevrolet Corvette Z06 46k mi.
    Black 2002 Subaru Impreza WRX 6-speed 94k mi. my mod list
    10/08/2006 - 14.089@103.01 (5-speed with well worn clutch, no launch)
    "Six stars gleaming, five speeds breaking, four tires chirping, three differentials working, two liters screaming, one turbo boosting... it's what makes a Subaru all-wheel-drive, all we'll drive."
    for Bugeye owners my BOV thread Service Manuals

  5. #4
    Registered User hakira's Avatar
    Join Date
    May 2004
    Location
    Slidell, La
    Posts
    413
    dont' see how the code just disappears unless you reset the ecu. and you have an high idle. i belive most are around 800 at normal engine tempretures
    02' WRX OSECUROM STG 2 93OCT on 91OCT map -13.708 SEC / 097.84 MPH / 1.86 60 ft @ No Problem Raceway

    02' WRX OSECUROM STG 2.5 93OCT- 12.9 SEC @ No Problem Raceway
    Mods

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •