Just got my car serviced and now it drives different....
Results 1 to 6 of 6

This is a discussion on Just got my car serviced and now it drives different.... within the General Maintenance, Troubleshooting & Accidents. forums, part of the Tech & Modifying & General Repairs category; hey guys i had my car in the shop yesterday becuase my clutch blew out. Now i have my car ...

  1. #1
    Registered User Feezor's Avatar
    Join Date
    Nov 2006
    Location
    Ca
    Posts
    438

    Just got my car serviced and now it drives different....

    hey guys i had my car in the shop yesterday becuase my clutch blew out. Now i have my car back and my clutch pedel is much softer. Beofre my clutch was firm now it is very easy to push and has little resistance. Is this normal????


    Also now that i have my car back it seems to not have the power as it did before i took it to the shop. Now when i hit the gas im wondering why am i not passing people and why am i not going faster. Before i woul hit the gas and go, now it seems to be less of a go. Everything in the car is stock and i have not modified anything


    Any ideas on anything would help. Thanks!
    Last edited by Feezor; 06-13-2007 at 01:25 PM.

  2. Remove Advertisements
    ClubWRX.net
    Advertisements
     

  3. #2
    Registered User VinWRX28's Avatar
    Join Date
    Apr 2007
    Location
    New Brunswick
    Posts
    70
    Wow... my car is in the shop rite now too. Same old problem.. tranny went bad. the soft pedal feeling is normal. You got a new clutch and pressure plate.. maybe ur mechanic.. replace a pressure plate with less clamping force... so ur powers are slipping thru the clutch. ...Maybe

  4. #3
    Registered User se7en's Avatar
    Join Date
    May 2007
    Location
    Southern California
    Posts
    191
    Bleed the clutch. As for the power loss, check for air leaks.
    "A man that buys a Corvette has a mid-life crisis, but a man that buys a Lambourghini has NO crisis." -Rev Run

  5. #4
    Registered User 4play kzn's Avatar
    Join Date
    Mar 2007
    Posts
    43
    could be the ecu was reset.. and its learning max values again..
    drive for a while and see if it improves..

    if u have a boost gauge, check if the car is boosting the same as before..

  6. #5
    Registered User
    Join Date
    Feb 2006
    Location
    Siren, WI
    Posts
    231
    Unless you had a "super clutch" put in, the pedal may feel easier...usually a good shop will clean and lube the parts of the clutch...

    I know when I replaced mine with a mildly upgraded stage 1 organic, I was expecting a stiff pedal...to my delight it went down easier than it did before.

  7. #6
    Registered User Feezor's Avatar
    Join Date
    Nov 2006
    Location
    Ca
    Posts
    438
    ive checked just about everything the only thing that i keep thinking is what if they put in a hevier flywheel thats the only thing i can think becuase i have drove it for about 70-75 miles and it is not preforming any better and the computer learning thing i did the fast re-learn process right when the ecu got re-set and that didnt seem to work thanks for all your help

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •