Odd squeak when hitting bumps - Page 2
Page 2 of 2 FirstFirst 12
Results 16 to 24 of 24

This is a discussion on Odd squeak when hitting bumps within the General Maintenance, Troubleshooting & Accidents. forums, part of the Tech & Modifying & General Repairs category; Originally Posted by rr1911 does your sway-bars and/or endlinks have grease nipples like this ? No just standard metal brackets ...

  1. #16
    Registered User D0WNxSH1FT's Avatar
    Join Date
    Oct 2004
    Location
    Westchester Cnty, NY
    Posts
    6,545
    Quote Originally Posted by rr1911 View Post
    does your sway-bars and/or endlinks have grease nipples like this ?
    No just standard metal brackets and rubber bushings. ...still waiting to drive the car.
    2008 Satin White Pearl WRX Sedan w/ Navi
    2005 San Remo Red WRX Sedan w/ VF34 (traded)
    Pi Kappa Alpha | New England Flat 4

  2. Remove Advertisements
    ClubWRX.net
    Advertisements
     

  3. #17
    Administrator TheJ's Avatar
    Join Date
    Jul 2002
    Location
    Bro do you even live in the Dirty South
    Posts
    17,919
    I Support ClubWRX

    Smile

    I occasionally had this problem on my 04STi... I just turned the radio up and it went away.
    -The J
    New Members, CLICK & BOOKMARK these links:


    "Driving most supercars is like trying to manhandle a cow up a back staircase. . . This is like smearing honey into Keira Knightly" -JC

  4. #18
    Registered User D0WNxSH1FT's Avatar
    Join Date
    Oct 2004
    Location
    Westchester Cnty, NY
    Posts
    6,545
    Quote Originally Posted by TheJ View Post
    I occasionally had this problem on my 04STi... I just turned the radio up and it went away.
    Hahah yea that's what I have been doing but now that i've moved just outside of boston I have to drive everywhere and i swear that the DOT here are the WORST pavers ever. Every single road is bumpy, has pot holes, has a sunken man-hole, etc. Its horrible.
    2008 Satin White Pearl WRX Sedan w/ Navi
    2005 San Remo Red WRX Sedan w/ VF34 (traded)
    Pi Kappa Alpha | New England Flat 4

  5. #19
    Resident meany-rator 06wrx4me's Avatar
    Join Date
    Jun 2006
    Location
    Nor Cal
    Posts
    11,435
    I Support ClubWRX
    My aftermarket sway bars squeak bad
    2014 Ford Fiesta ST

    06 WRX, HAWKEYE # 001 <T-boned and sold>

    COILOVER TABLE
    TURBO TABLE

  6. #20
    Registered User D0WNxSH1FT's Avatar
    Join Date
    Oct 2004
    Location
    Westchester Cnty, NY
    Posts
    6,545
    ok guys, greasing the sway bar bushings did nothing lol. The noise is definetly from the inside of the car, its too soft yet high pitched squeak to be under the car. I think its gotta be the strut tops. ugh.
    2008 Satin White Pearl WRX Sedan w/ Navi
    2005 San Remo Red WRX Sedan w/ VF34 (traded)
    Pi Kappa Alpha | New England Flat 4

  7. #21
    Registered User wrx wagone's Avatar
    Join Date
    May 2005
    Location
    Phillytown, PA
    Posts
    10,774
    I guess, but everything in there that really mounts to something has rubber on it. I really don't see that squeaking, and honestly if anything was really loose with the strut tops it should make a nice clunk sound.

    Good luck.
    This message printed on 100% recycled electrons.

  8. #22
    Registered User rr1911's Avatar
    Join Date
    Nov 2005
    Location
    Central Florida
    Posts
    0
    did u find the noise and/or fixed it yett ?
    Army Ranger For Life ! Thin Blue Line
    Military Militia # 1911/ Blobeye Syndicate # 1911/ Modifier's Anonymous # 1911/ Hawk-Eye Alliance # 1911
    All We'll Drive
    DIFFERENT STROKES
    EVEN MY DENTIST TOLD ME FLOSS 7 DAYS A WEEK
    POST WH0RE KING

  9. #23
    Registered User D0WNxSH1FT's Avatar
    Join Date
    Oct 2004
    Location
    Westchester Cnty, NY
    Posts
    6,545
    I've been in Florida for the past week but even before that, I was not able to fix the issue. It is very annoying.
    2008 Satin White Pearl WRX Sedan w/ Navi
    2005 San Remo Red WRX Sedan w/ VF34 (traded)
    Pi Kappa Alpha | New England Flat 4

  10. #24
    Registered User
    Join Date
    Jun 2007
    Location
    Houston Texas
    Posts
    17
    My 2002 has the same problem....it is annoying...

Page 2 of 2 FirstFirst 12

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •