Weird sound from the turbo, options?
+ Reply to Thread
Results 1 to 6 of 6

This is a discussion on Weird sound from the turbo, options? within the General Maintenance, Troubleshooting & Accidents. forums, part of the Tech & Modifying & General Repairs category; Ever since I bought my car, it has made a weird almost 'flapping' sound from the turbo, almost right in ...

  1. #1
    Nok
    Nok is offline
    Registered User Nok's Avatar
    Join Date
    Jul 2006
    Location
    STG, UT
    Posts
    75

    Weird sound from the turbo, options?

    Ever since I bought my car, it has made a weird almost 'flapping' sound from the turbo, almost right in the middle of it's spool. When it's spooling low, it's quiet, and spooled high it's quiet...

    Anyway, last time I took it in for the oil change they told me that it isn't causing any problems, and I have nothing to worry about. So I'm past worrying about it, but I've decided that I didn't pay for my car to sound like trash, and I'm sick of it.

    Can I go into my dealership and force them to fix/replace the turbo, until the sound is gone? Or does it technically have to be "broken" in order for it to be covered? I've searched around and can't find any close answers, so any help would be awesome!

  2. Remove Advertisements
    ClubWRX.net
    Advertisements
     

  3. #2
    Registered User bcyb1029's Avatar
    Join Date
    Feb 2006
    Location
    Chicago
    Posts
    3,021
    if it is just after you let off the throttle it is normal .
    Tuned by Jorge at P&L, 240.83whp 239.60wtq at 14.8psi on 2.0L with stock td04 (But doesn't run)

  4. #3
    Nok
    Nok is offline
    Registered User Nok's Avatar
    Join Date
    Jul 2006
    Location
    STG, UT
    Posts
    75
    Quote Originally Posted by bcyb1029 View Post
    if it is just after you let off the throttle it is normal .
    No, it's nothing close to that sound...

    As I step on the gas, if I'm accelerating even a little bit the sound starts and it is really loud as long as the turbo is spooled around the 0 range. Basically, if I am accelerating any faster than a slight increase, it flutters the whole time I am pushing on the gas.

  5. #4
    Banned Subie do's Avatar
    Join Date
    Apr 2006
    Location
    Seattle WA.
    Posts
    2,595
    Could be wastegate flutter? Is your car stock?

  6. #5
    Nok
    Nok is offline
    Registered User Nok's Avatar
    Join Date
    Jul 2006
    Location
    STG, UT
    Posts
    75
    Yea, bone stock

  7. #6
    Registered User
    Join Date
    Nov 2006
    Location
    Las Vegas, NV
    Posts
    14
    i got something like that, except its LOUD as hell and i'm getting NO boost and it almost sounds like somethin rattles a bit too. I think my turbo is done

+ Reply to Thread

Quick Reply Quick Reply

Register Now

Please enter the name by which you would like to log-in and be known on this site.
If you do not want to register, fill this field only and the name will be used as user name for your post.

Please enter a password for your user account. Note that passwords are case-sensitive.

Please enter a valid email address for yourself. We strongly suggest that you stay away from using aol, yahoo, msn, and hotmail accounts. Sometimes the mail server blocks the emails from our server. As a result you will not receive any notifications including the confirmation email.

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.


Posting Permissions

  • You may post new threads
  • You may post replies
  • You may not post attachments
  • You may not edit your posts
  •