MAF Shot?
+ Reply to Thread
Results 1 to 5 of 5

This is a discussion on MAF Shot? within the General Maintenance, Troubleshooting & Accidents. forums, part of the Tech & Modifying & General Repairs category; Hi to everyone, I currently have a very slow Turbo 2000 (MY99), the car has a few mods, JR Panel, ...

  1. #1
    Registered User
    Join Date
    May 2007
    Location
    Somerset, England
    Posts
    3

    Red face MAF Shot?

    Hi to everyone,

    I currently have a very slow Turbo 2000 (MY99), the car has a few mods, JR Panel, Prodrive rear box, decat centre & TD05 (was planning a remap). The car has been running fine with these mods but now (6 months on)has started to develop a misfire (as boost comes in), the plugs have been changed (gapped to 0.65mm), new leads and a new intake hose have been fitted (old one was split) but the problem is still evident (boost gauge is showing a good 15psi). The car seems to be running way to rich as the plugs were really sooty and the idle is all over the place. I have tried resetting the ecu and this just made everything worse! Could this be the MAF problem I have read so much about? The car has done around 118,000 miles (mostly on the motorway) but the engine is quiet and doesn't use any oil. Anyone else had a similar problem?

  2. Remove Advertisements
    ClubWRX.net
    Advertisements
     

  3. #2
    Registered User xMDxWRX's Avatar
    Join Date
    Jan 2006
    Location
    Towson MD
    Posts
    1,337
    do you have a tune? and do you have catless exhaust?
    2004 VW GLI "Back In Boost "

    Quote Originally Posted by KanoWRX View Post
    well...IMO, or IMI (In My Imagination) WRX's/STi's are still better that Evo's...hands down...despise the facts.........

  4. #3
    Registered User
    Join Date
    May 2007
    Location
    Somerset, England
    Posts
    3
    Quote Originally Posted by xMDxWRX View Post
    do you have a tune? and do you have catless exhaust?
    Map is standard, downpipe is original with cat

  5. #4
    Registered User xMDxWRX's Avatar
    Join Date
    Jan 2006
    Location
    Towson MD
    Posts
    1,337
    Quote Originally Posted by SickWagon View Post
    Map is standard, downpipe is original with cat
    What map? like stock?
    2004 VW GLI "Back In Boost "

    Quote Originally Posted by KanoWRX View Post
    well...IMO, or IMI (In My Imagination) WRX's/STi's are still better that Evo's...hands down...despise the facts.........

  6. #5
    Registered User
    Join Date
    May 2007
    Location
    Somerset, England
    Posts
    3
    Quote Originally Posted by xMDxWRX View Post
    What map? like stock?
    Yes unfortunately

+ Reply to Thread

Quick Reply Quick Reply

Register Now

Please enter the name by which you would like to log-in and be known on this site.
If you do not want to register, fill this field only and the name will be used as user name for your post.

Please enter a password for your user account. Note that passwords are case-sensitive.

Please enter a valid email address for yourself. We strongly suggest that you stay away from using aol, yahoo, msn, and hotmail accounts. Sometimes the mail server blocks the emails from our server. As a result you will not receive any notifications including the confirmation email.

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.


Posting Permissions

  • You may post new threads
  • You may post replies
  • You may not post attachments
  • You may not edit your posts
  •