Need Help: WRX Problem
Results 1 to 3 of 3

This is a discussion on Need Help: WRX Problem within the General Maintenance, Troubleshooting & Accidents. forums, part of the Tech & Modifying & General Repairs category; I Have a 04 Subaru wrx with about 53,000 miles. The current mods on it are; aps 3.5 turbo back ...

  1. #1
    Registered User
    Join Date
    May 2007
    Location
    Massachusetts
    Posts
    9

    Unhappy Need Help: WRX Problem

    I Have a 04 Subaru wrx with about 53,000 miles. The current mods on it are;

    aps 3.5 turbo back exhaust
    forge blow off vavle
    cobb intake
    cobb short shifter

    As of a couple weeks ago I have been having some problems. When I Step on the gas pedal all the way to the floor the car doesn't go anywhere. The boost climes to 14 psi and the engine sounds ok but it doesn't go that fast. When I hit around 5000 rpms the car finally takes off. (It feels like the worst case of turbo lag in the world). If I feather the gas pedal and slowly push it all the way down It goes fine. Also when I hit 6000 rpms my car just (shuts down). It stays running but it feels like someone cuts off the fuel. Im hoping that a well needed tune up including spark plugs and fuel filter will take care of this problem. Does anyone have any ideas what this could be???

    Please give me some ideas..

  2. Remove Advertisements
    ClubWRX.net
    Advertisements
     

  3. #2
    Registered User perfusionista's Avatar
    Join Date
    May 2004
    Location
    Boulder County, CO
    Posts
    378
    Quote Originally Posted by 976pgd View Post
    When I Step on the gas pedal all the way to the floor the car doesn't go anywhere. The boost climes to 14 psi and the engine sounds ok but it doesn't go that fast. When I hit around 5000 rpms the car finally takes off. (It feels like the worst case of turbo lag in the world). If I feather the gas pedal and slowly push it all the way down It goes fine.
    This sounds like your clutch is slipping. V bad.

    Also when I hit 6000 rpms my car just (shuts down). It stays running but it feels like someone cuts off the fuel.
    This sounds just like the over-rev protection, which does cut off the fuel flow when you hit red-line, though 6,000 seems too early.

  4. #3
    Registered User btrenhol's Avatar
    Join Date
    Oct 2006
    Location
    Fort Collins, Colorado
    Posts
    143
    +1 to clutch slipping
    sounds like fuel cut from the rev sensor not matching up with the engine speed.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •