problems with my new car,pls help the newb
Results 1 to 5 of 5

This is a discussion on problems with my new car,pls help the newb within the General Maintenance, Troubleshooting & Accidents. forums, part of the Tech & Modifying & General Repairs category; my 04 wrx with about 60k mi on it has a hard time shifting when first warming up. about 15 ...

  1. #1
    Registered User wr-ecks's Avatar
    Join Date
    May 2007
    Location
    bonney lake
    Posts
    32

    problems with my new car,pls help the newb

    my 04 wrx with about 60k mi on it has a hard time shifting when first warming up. about 15 min in its fine. i just got it a few weeks ago and it wasnt like this when i got it. its not really bad but there is noticable resistance there. i think it may be a clutch problem as this has happened to me before just like this except it didnt go away after the car warmed up. maybe it just needs the fluid changed? maybe something in the tranny i dont know, any opinions on what my problem is would be welcome. i am about to put in a new clutch anyways but if there is another problem id like to address it at the same time.

  2. Remove Advertisements
    ClubWRX.net
    Advertisements
     

  3. #2
    Resident meany-rator 06wrx4me's Avatar
    Join Date
    Jun 2006
    Location
    Nor Cal
    Posts
    11,405
    I Support ClubWRX
    Welcome to the wonderful world of the wrx 5MT. Common problem in cold environments. Alas your shifting woes will be eased considerably if you switch your fluid. click the link in my sig for tranny fluid. Change the fluid before you commit to the clutch. Might solve your problem.
    2014 Ford Fiesta ST

    06 WRX, HAWKEYE # 001 <T-boned and sold>

    COILOVER TABLE
    TURBO TABLE

  4. #3
    Moderator
    Join Date
    Jul 2003
    Location
    Maryland
    Posts
    11,098
    I Support ClubWRX
    Yup it's fairly common. My wrx was miserable in the winter until it was warmed up. Forget about downshifting into 2nd for several mins.

    My STI has some of these issues but it's not nearly as bad.
    0-60 faster then your first sexual experience.
    "You've come far, and though you're far from the end
    You don't mind where you are, cause you know where you've been"

  5. #4
    He simply abides. SD_GR's Avatar
    Join Date
    Jul 2002
    Location
    CA, US
    Posts
    22,317
    I Support ClubWRX
    If the problem was not there previously it could be a leak or air in the system. Check the clutch fluid level and see if it's low. If it is, you are likely losing some.
    WRX Info Links, Courtesy TheJ
    The world breaks everyone and afterward many are strong in the broken places. Ernest Hemingway
    I lied. I cheated. I bribed men to cover the crimes of other men. I am an accessory to murder. But the most damning thing of all... I think I can live with it. And if I had to do it all over again - I would. Benjamin Sisko
    DISCLAIMER: Opinions expressed are the author's alone and are inherently worthless.

  6. #5
    Registered User wr-ecks's Avatar
    Join Date
    May 2007
    Location
    bonney lake
    Posts
    32
    clutch fluid level is ok. and the pedal feels the same too.i know it sounds weird but it did bad for a couple days and now its back to normal. its a little sticky first thing in the morning but i guess its a common problem with these. i plan on doing a new turbo and a few other things in the near future anyways so a new clutch i think would be a good idea anyways. thanks for the help

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •