wrx losing power
+ Reply to Thread
Results 1 to 4 of 4

This is a discussion on wrx losing power within the General Maintenance, Troubleshooting & Accidents. forums, part of the Tech & Modifying & General Repairs category; Right my problem is that when I am in 5th gear travelling at 70 mph on the motorway the car ...

  1. #1
    Registered User ulsterscooby's Avatar
    Join Date
    Apr 2007
    Location
    Antrim Northern Ireland
    Posts
    15

    wrx losing power

    Right my problem is that when I am in 5th gear travelling at 70 mph on the motorway the car behaves like I have wrongly selected the gear ie gone into 5th when I meant to select say 2nd gear at about 20mph. The ride is sluggish and there is very little acceleration when I push the peddle has anybody any ideas what could be causing this ?

    I have also noticed that the boost takes much longer to build up in the lower gears although my Bov can be heard to operate on gear changes
    Thanks in advance

  2. Remove Advertisements
    ClubWRX.net
    Advertisements
     

  3. #2
    Registered User D0WNxSH1FT's Avatar
    Join Date
    Oct 2004
    Location
    Westchester Cnty, NY
    Posts
    6,545
    Quote Originally Posted by ulsterscooby View Post
    Right my problem is that when I am in 5th gear travelling at 70 mph on the motorway the car behaves like I have wrongly selected the gear ie gone into 5th when I meant to select say 2nd gear at about 20mph. The ride is sluggish and there is very little acceleration when I push the peddle has anybody any ideas what could be causing this ?

    I have also noticed that the boost takes much longer to build up in the lower gears although my Bov can be heard to operate on gear changes
    Thanks in advance
    First of all 5th gear should not have a lot of power as the engine is now spinning as fast as in say 3rd gear. If you downshift to 4th or 3rd on the highway you will get back all of the performance that you are missing.

    Boost should increase faster in lower gears.

    Why do you have a blow-off valve? That is probably causing issues as well.
    2008 Satin White Pearl WRX Sedan w/ Navi
    2005 San Remo Red WRX Sedan w/ VF34 (traded)
    Pi Kappa Alpha | New England Flat 4

  4. #3
    Registered User tayhadar1's Avatar
    Join Date
    Apr 2006
    Location
    Spokane, WA
    Posts
    1,509
    Quote Originally Posted by D0WNxSH1FT View Post
    Why do you have a blow-off valve? That is probably causing issues as well.
    +1
    2004 WRX Sti Cobb Stage 2
    GO COUGS!!!

  5. #4
    Registered User 68sprintb's Avatar
    Join Date
    Dec 2005
    Location
    San Jose, CA
    Posts
    434
    5th is for cruising, not power, so that sounds perfectly normal
    Blobeye Syndicate #75
    2005 OBP WRX Sport Wagon
    Stewart Warner Boost & Oil temp gauges / OEM 20 mm rear bar
    Cobb stg 2 / STi uppipe / Crucial Racing downpipe
    Stromung 2.5" catless centerpipe / Scooby Sport New Age centre pipe & backbox

+ Reply to Thread

Quick Reply Quick Reply

Register Now

Please enter the name by which you would like to log-in and be known on this site.
If you do not want to register, fill this field only and the name will be used as user name for your post.

Please enter a password for your user account. Note that passwords are case-sensitive.

Please enter a valid email address for yourself. We strongly suggest that you stay away from using aol, yahoo, msn, and hotmail accounts. Sometimes the mail server blocks the emails from our server. As a result you will not receive any notifications including the confirmation email.

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.


Posting Permissions

  • You may post new threads
  • You may post replies
  • You may not post attachments
  • You may not edit your posts
  •