Horn and cruise control wont work
+ Reply to Thread
Results 1 to 9 of 9

This is a discussion on Horn and cruise control wont work within the General Maintenance, Troubleshooting & Accidents. forums, part of the Tech & Modifying & General Repairs category; So i'm getting no power to my steering wheel. no horn, cruise control, and i have my air bag light ...

  1. #1
    Registered User
    Join Date
    Apr 2007
    Location
    NC
    Posts
    2

    Horn and cruise control wont work

    So i'm getting no power to my steering wheel. no horn, cruise control, and i have my air bag light on which i figure is b/c its not reading my steering wheel one. oh yeah its an 02' wrx. i checked all the fuses under the hood and along the drivers side. so is there a relay or something i'm missing. i already checked the connection at the steering wheel and its seems good unless there's on i can't see.

  2. Remove Advertisements
    ClubWRX.net
    Advertisements
     

  3. #2
    Registered User mittermiers's Avatar
    Join Date
    Jan 2007
    Location
    Latvia
    Posts
    25
    This post also intrests me.
    My cruise control doesn't worl also, i cant figure out why, everything seems to be in working ordet all fuses and conectionas are ok

  4. #3
    Registered User
    Join Date
    Apr 2007
    Location
    NC
    Posts
    2
    so i decided to go a little deeper into troubleshooting, and i pulled the airbag and steeringwheel off. i'm thinking it might be the switch which connects everything on the steering wheel to the column. i just need to get a hold of a multimeter to see if i have a good connection there. if not than i know what it is.

  5. #4
    Registered User Tek-Fox's Avatar
    Join Date
    Apr 2006
    Location
    Denver
    Posts
    107
    I had the same problem. The fuse kept blowing on my horn/cruise control, it turned out to be a short in one of the steering wheel circuits. Fixed it at the dealer.

  6. #5
    Registered User
    Join Date
    Jan 2009
    Location
    Albany NY
    Posts
    30
    Has anyone found a fix to this problem? My Horn, and cruise control doesn't work and the Airbag light is now on....LIVID!

    Did anyone find out if the switch in the steering wheel is to blame or what?

    Thanks
    2002 WRX

  7. #6
    Registered User EvoEatr's Avatar
    Join Date
    Aug 2008
    Location
    Kennett Square, Pennsylvania
    Posts
    1,839
    Quote Originally Posted by eshaze View Post
    Has anyone found a fix to this problem? My Horn, and cruise control doesn't work and the Airbag light is now on....LIVID!

    Did anyone find out if the switch in the steering wheel is to blame or what?

    Thanks
    Assuming you have checked the fuses?

  8. #7
    Registered User
    Join Date
    Jan 2009
    Location
    Albany NY
    Posts
    30
    All the fuses are fine unfortunately, I just have to assume the clock spring is faulty!
    2002 WRX

  9. #8
    Registered User
    Join Date
    Jun 2010
    Location
    florida
    Posts
    4
    its the roll connecter or "clock spring". you will need to disconnect the battery, pull the air bag out of the wheel. mark the steering wheel cog and the steering column spline with permanent marker. Keeping the front wheels straight, take off the steering wheel and you will see the roll connecter, its a circle with an arrow on the bottom and a yellow sticker. replace that, line everything back up and you will be good to go. I replaced the steering rack in my 02 and spun the wheel like an idiot, POP goes the very expensive part! hope that helps. Please do not force the roll connecter on or off and make sure the arrow on the roll connecter matches the one on the column.

  10. #9
    Registered User EvoEatr's Avatar
    Join Date
    Aug 2008
    Location
    Kennett Square, Pennsylvania
    Posts
    1,839
    Quote Originally Posted by slow02 View Post
    its the roll connecter or "clock spring". you will need to disconnect the battery, pull the air bag out of the wheel. mark the steering wheel cog and the steering column spline with permanent marker. Keeping the front wheels straight, take off the steering wheel and you will see the roll connecter, its a circle with an arrow on the bottom and a yellow sticker. replace that, line everything back up and you will be good to go. I replaced the steering rack in my 02 and spun the wheel like an idiot, POP goes the very expensive part! hope that helps. Please do not force the roll connecter on or off and make sure the arrow on the roll connecter matches the one on the column.
    Also make sure you wait at least 10 min. after you disconnect the battery, there are capacitors in the airbag control module that need to discharge in that time...

+ Reply to Thread

Quick Reply Quick Reply

Register Now

Please enter the name by which you would like to log-in and be known on this site.
If you do not want to register, fill this field only and the name will be used as user name for your post.

Please enter a password for your user account. Note that passwords are case-sensitive.

Please enter a valid email address for yourself. We strongly suggest that you stay away from using aol, yahoo, msn, and hotmail accounts. Sometimes the mail server blocks the emails from our server. As a result you will not receive any notifications including the confirmation email.

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.


Posting Permissions

  • You may post new threads
  • You may post replies
  • You may not post attachments
  • You may not edit your posts
  •