can anyone tell me what this is?
Results 1 to 6 of 6

This is a discussion on can anyone tell me what this is? within the General Maintenance, Troubleshooting & Accidents. forums, part of the Tech & Modifying & General Repairs category; It looks like this hose should be connected. I haven't noticed anything strange while driving the car though. Can anyone ...

  1. #1
    Registered User drive4fun's Avatar
    Join Date
    Dec 2006
    Location
    ID
    Posts
    47

    can anyone tell me what this is?

    It looks like this hose should be connected. I haven't noticed anything strange while driving the car though. Can anyone tell me if this is normal or if I should connect this?
    Attached Thumbnails Attached Thumbnails Img_6983.jpg   Img_6984.jpg  
    04' WRX

  2. Remove Advertisements
    ClubWRX.net
    Advertisements
     

  3. #2
    Is in Love With the Admins Here 20WRX04's Avatar
    Join Date
    Nov 2004
    Location
    WNY
    Posts
    2,772
    I would connect it ASAP. If you don't, your flux capacitor will disengage prematurely resulting in catastrophic thermal meltdown. For real though, it should be connected.
    The first rule of the Faction is...DO NOT TALK ABOUT THE FACTION.
    NY GIANTS
    Hybrid Faction #19
    Blobeye Syndicate #19
    Mods

  4. #3
    Registered User drive4fun's Avatar
    Join Date
    Dec 2006
    Location
    ID
    Posts
    47
    Do you know what it is? I have no idea how long it's been disconnected...

    And I hear flux capacitors can be really expensive to replace
    04' WRX

  5. #4
    Boba Fett BrianH's Avatar
    Join Date
    Oct 2003
    Location
    Way up high.
    Posts
    17,933
    something recirculating air back to your intake. I've not been under the hood in years but I'm guessing that it comes from the stock BCS. That venting to atmosphere isn't a problem, the problem is that your intake is pulling in air through that hole which is bypassing the maf and possibly causing you to run lean.

  6. #5
    Registered User rr1911's Avatar
    Join Date
    Nov 2005
    Location
    Central Florida
    Posts
    0
    Quote Originally Posted by BrianH View Post
    something recirculating air back to your intake. I've not been under the hood in years but I'm guessing that it comes from the stock BCS. That venting to atmosphere isn't a problem, the problem is that your intake is pulling in air through that hole which is bypassing the maf and possibly causing you to run lean.
    +1
    Army Ranger For Life ! Thin Blue Line
    Military Militia # 1911/ Blobeye Syndicate # 1911/ Modifier's Anonymous # 1911/ Hawk-Eye Alliance # 1911
    All We'll Drive
    DIFFERENT STROKES
    EVEN MY DENTIST TOLD ME FLOSS 7 DAYS A WEEK
    POST WH0RE KING

  7. #6
    Registered User drive4fun's Avatar
    Join Date
    Dec 2006
    Location
    ID
    Posts
    47
    Quote Originally Posted by BrianH View Post
    something recirculating air back to your intake. I've not been under the hood in years but I'm guessing that it comes from the stock BCS. That venting to atmosphere isn't a problem, the problem is that your intake is pulling in air through that hole which is bypassing the maf and possibly causing you to run lean.
    Thanks. I've got it hooked back up now. Do I just cross my fingers and hope that it hasn't done any long term damage? If it was bypassing the maf, shouldn't that have thrown a cel?
    04' WRX

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •