No boost! yes i am a newb, help me!
Results 1 to 10 of 10

This is a discussion on No boost! yes i am a newb, help me! within the General Maintenance, Troubleshooting & Accidents. forums, part of the Tech & Modifying & General Repairs category; totally fine with admitting that i am a newb..... so i am driving home from Subiefest (was a cool event!) ...

  1. #1
    Registered User eddiecut's Avatar
    Join Date
    Mar 2007
    Location
    Bend
    Posts
    11

    No boost! yes i am a newb, help me!

    totally fine with admitting that i am a newb..... so i am driving home from Subiefest (was a cool event!) and i notice my car is being a total pig, start listening and then i look at the boost gauge and no preasure... dont feel the turbo, no spool noise.. NOTHING... it idles fine, it doesnt have any engine lights, runs fine... besides being slower then crap... any ideas?
    i checked hoses and connections to see if there might be a boost leak or something, please help...

    thanks a ton!

  2. Remove Advertisements
    ClubWRX.net
    Advertisements
     

  3. #2
    Registered User PJO42387's Avatar
    Join Date
    May 2006
    Location
    DF-DUB
    Posts
    2,386
    mods?
    CGM

  4. #3
    Registered User eddiecut's Avatar
    Join Date
    Mar 2007
    Location
    Bend
    Posts
    11

    Red face

    i bought the car two weeks ago from a dealer, from what i can see it has an sti intercooler, sti exhuast, maybe a different dowpipe and intake tube, but not 100% on that... this is the first subaru i have owned...

    but i thought if something bad would have happened then a check engine light or something would have came up... all it does is run like there is no turbo and is really really slow, bogs down going over the pass and such...

    would a turbo seize? and just not spin anymore?
    i thought itmight have been a boost leak but i cannot find a loose hose or anything... checked oil.. looks fine, coolent is fine.... just no boost at all... idles fine, runs fine besides being slow....

    it is still under warranty but, would the STI intercooler and stuff void that?

  5. #4
    Registered User 06fx4's Avatar
    Join Date
    Mar 2007
    Posts
    19
    how about some more details on the car, and maybe some pics of these questionable mods?
    2006 Ford F-150 - Black - 8" Rize ind. Lift - 37,13.50,20 Toyo Open Country M/T's - 20x10 Moto Metal 951's - Edge Evolution Custom Tune - AirRaid Modular Intake - Westin Bull Bar - 150w KC Daylighters

    Next in Line is an STI

  6. #5

    Princess Moderator

    03WRX_YELLOW's Avatar
    Join Date
    May 2004
    Location
    Gresham, Oregon
    Posts
    14,843
    I Support ClubWRX
    Quote Originally Posted by eddiecut View Post
    i bought the car two weeks ago from a dealer, from what i can see it has an sti intercooler, sti exhuast, maybe a different dowpipe and intake tube, but not 100% on that... this is the first subaru i have owned...

    but i thought if something bad would have happened then a check engine light or something would have came up... all it does is run like there is no turbo and is really really slow, bogs down going over the pass and such...

    would a turbo seize? and just not spin anymore?
    i thought itmight have been a boost leak but i cannot find a loose hose or anything... checked oil.. looks fine, coolent is fine.... just no boost at all... idles fine, runs fine besides being slow....

    it is still under warranty but, would the STI intercooler and stuff void that?

    You have PM. And from what you have decribed... it sounds like Turbo siezed on you.
    Jennifer - "Consigliere" for the Bugeye Mafia
    ScoobyDMCtt - Blobeye Syndicate #007
    04 STi ECU - with Protune - FSTi Garrett GT40 -- 422whp-more to come... 12.86 @ 105

    BoBBy TuNED@ preracing.com --- DIFFERENT STROKES

  7. #6
    Registered User
    Join Date
    May 2007
    Posts
    1

    Angry same here

    my car started doing the same thing last night. di you find out what it is?
    i have intake cat back exhaust BOV and vf30

  8. #7
    Registered User D0WNxSH1FT's Avatar
    Join Date
    Oct 2004
    Location
    Westchester Cnty, NY
    Posts
    6,545
    Quote Originally Posted by atarin18 View Post
    my car started doing the same thing last night. di you find out what it is?
    i have intake cat back exhaust BOV and vf30
    Remove your BOV as it is useless and harming your car.
    2008 Satin White Pearl WRX Sedan w/ Navi
    2005 San Remo Red WRX Sedan w/ VF34 (traded)
    Pi Kappa Alpha | New England Flat 4

  9. #8
    Registered User ulsterscooby's Avatar
    Join Date
    Apr 2007
    Location
    Antrim Northern Ireland
    Posts
    15
    Try checking your plugs and leads i had a similar issue with my 1993 wrx jdm import turned out to be a faulty coil pack

  10. #9
    Registered User BONES1672's Avatar
    Join Date
    May 2006
    Location
    Williamsport, PA / Ewing, NJ
    Posts
    83
    My car is having the same problem. No boost, in any gear, even full throttle. Doesn't break 0 MPa. No weird noises, bpv's tight, hoses seem to be on correctly.

    I drove the morning this problem started, and everything was fine, I went out to get some poster supplies and everything boosted fine. 4 hours later, I'm driving to work and all of the sudden I have no boost at all. Not even wastegate pressure.

    Anyone know what this is?

    Thanks a lot,
    -Brandon
    03 wrb WRX
    Power- Cobb Stage 2 w/ TXS stealthback, 06 axleback, and 07 catless uppipe
    Handling- Eibach Springs, Perrin Rear Sway Bar, Perrin Rear Sway Mounts, Perrin Rear Endlinks, STi strut bars
    Cosmetics- cf wing risers, pink "i" badge, yellow fogs, STI CF side markers, tints, tail lights,

  11. #10
    Registered User
    Join Date
    Mar 2007
    Posts
    23
    hey guys, I know im a noob and this has been bothering me for a long time, whats the stock turbo in the 05 WRX and whats the stock PSI that they come with and last question the size of the wastegate thats in the 05 WRX thanks alot

    love subaru

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •