Strange noise from turbo after stage 2
Results 1 to 2 of 2

This is a discussion on Strange noise from turbo after stage 2 within the General Maintenance, Troubleshooting & Accidents. forums, part of the Tech & Modifying & General Repairs category; I have an 05 WRX with uppipe, catless downpipe, snorkel removed, and XPT stage 2 map and 30K. about 500 ...

  1. #1
    Registered User
    Join Date
    Feb 2007
    Location
    SW PA
    Posts
    4

    Strange noise from turbo after stage 2

    I have an 05 WRX with uppipe, catless downpipe, snorkel removed, and XPT stage 2 map and 30K. about 500 miles after these mods, I started noticing a strange noice from I beleive the turbo. Its a loud whining only while the turbo is spooling, and only after sitting for a few moments. Once it spools its gone. It almost sounds like the compresser side is full of oil. I havent takin it apart yet, just wanted to see if anybody has had/heard of this. I did some logging and every thing looks good boost is a little low and the car feels like its loaded up after idling for a few moments, yet the oil level hasnt moved and it doesnt smoke at all

  2. Remove Advertisements
    ClubWRX.net
    Advertisements
     

  3. #2
    Registered User Knome's Avatar
    Join Date
    Dec 2006
    Location
    San Diego
    Posts
    301
    If its like a woosh wine then its just the turbo spooling. But if its happening while its spooling and a little bit after that you may have a boost leak.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •