wipers
+ Reply to Thread
Results 1 to 6 of 6

This is a discussion on wipers within the General Maintenance, Troubleshooting & Accidents. forums, part of the Tech & Modifying & General Repairs category; ok weird thing happening with my wipers. Sometimes they work too good and on there way up go and hit ...

  1. #1
    Registered User
    Join Date
    Nov 2006
    Location
    Lexington, KY
    Posts
    0

    wipers

    ok weird thing happening with my wipers. Sometimes they work too good and on there way up go and hit the A post and on the way down they hit the black plastic cover where they rest. Then sometimes they don't work good at all and they come about 5 inches from there normal position on the way up and down. What do you all think? Wiper motor? Electronics? Today I took the wiper arms off and they look ok. I looked at the connecting arm that controls the other wiper and it has some play in it. I think the motor has play in it for some reason which is causing the problem.. I don't know..

    Thanks
    Travis

  2. Remove Advertisements
    ClubWRX.net
    Advertisements
     

  3. #2
    Registered User 06grayrex's Avatar
    Join Date
    Mar 2006
    Location
    STL
    Posts
    379
    What are the weather conditions when this happens?
    Hawk-Eye Alliance #666
    Stage 2

  4. #3
    Registered User 68sprintb's Avatar
    Join Date
    Dec 2005
    Location
    San Jose, CA
    Posts
    434
    theres also a "park switch" that ensures the motor stops when it is supposed to... check the harness and connectors to the motor if you can, look for damage or corrosion, maybe even broken...
    Blobeye Syndicate #75
    2005 OBP WRX Sport Wagon
    Stewart Warner Boost & Oil temp gauges / OEM 20 mm rear bar
    Cobb stg 2 / STi uppipe / Crucial Racing downpipe
    Stromung 2.5" catless centerpipe / Scooby Sport New Age centre pipe & backbox

  5. #4
    Registered User zulater's Avatar
    Join Date
    May 2005
    Location
    Oklahoma
    Posts
    101
    Quote Originally Posted by FFTravisM View Post
    ok weird thing happening with my wipers. Sometimes they work too good and on there way up go and hit the A post and on the way down they hit the black plastic cover where they rest. Then sometimes they don't work good at all and they come about 5 inches from there normal position on the way up and down. What do you all think? Wiper motor? Electronics? Today I took the wiper arms off and they look ok. I looked at the connecting arm that controls the other wiper and it has some play in it. I think the motor has play in it for some reason which is causing the problem.. I don't know..

    Thanks
    Travis
    I'm having the same issue and it's annoying. my wiper blades actually go off the window and you can see them hanging off the car through the driver side window. I notice it more the faster i go. like if i'm doing 25-30 they are fine but anything above 45 makes them crash off the side of the car. I'm assuming play somewhere but i'm not real sure. 03 wrx here.

  6. #5
    Registered User
    Join Date
    Nov 2006
    Location
    Lexington, KY
    Posts
    0
    Here is what I found out. In the wiper control assembly there is a set of linkages and they connect via ball joints. Well the ball is metal and the joint is plastic and they tend to wear out sometimes. Well you can get a new one from your local subaru dealer for about 115.00 or online for about 85 plus shipping.. If you check junk yards they have them for cheap.. I will include a link of who I used and it was 25.00 plus 10.00 shipping. Here is two pictures detailing what went wrong.. The plastic white cap there is what wears out and caused my issues. You can not just buy the one arm you have to buy everything but the motor.. The removal and fixing is really easy.. Takes me abotu 10 minutes if that.

    Link to who I ordered from. (Not the fastest but good and cheap)
    http://www.halspartsandservice.com/



  7. #6
    Registered User zulater's Avatar
    Join Date
    May 2005
    Location
    Oklahoma
    Posts
    101
    Thanks very much that sounds like my problem.

+ Reply to Thread

Quick Reply Quick Reply

Register Now

Please enter the name by which you would like to log-in and be known on this site.
If you do not want to register, fill this field only and the name will be used as user name for your post.

Please enter a password for your user account. Note that passwords are case-sensitive.

Please enter a valid email address for yourself. We strongly suggest that you stay away from using aol, yahoo, msn, and hotmail accounts. Sometimes the mail server blocks the emails from our server. As a result you will not receive any notifications including the confirmation email.

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.


Posting Permissions

  • You may post new threads
  • You may post replies
  • You may not post attachments
  • You may not edit your posts
  •