Instrument Cluster lights go out when headlights turned on
+ Reply to Thread
Results 1 to 3 of 3

This is a discussion on Instrument Cluster lights go out when headlights turned on within the General Maintenance, Troubleshooting & Accidents. forums, part of the Tech & Modifying & General Repairs category; I am having a problem where my instrument panel lights don't come on when I turn on my headlights to ...

  1. #1
    Registered User
    Join Date
    Feb 2007
    Location
    Tucson, AZ
    Posts
    1

    Instrument Cluster lights go out when headlights turned on

    I am having a problem where my instrument panel lights don't come on when I turn on my headlights to park or on. The odometer which is always lit green goes out when I turn my exterior lights on. The lighting on my stereo still goes on and off like it should and all of my fuses are good. Here's my back story. I relocated my boost gauge from the A-pillar to my new autometer bezel. While rerouting my wires I had to disconnect my instrument cluster. After I put everything back together all of the gauges on my cluster worked fine until I turned on my headlights. That's when I found that my odometer light went out and my interior bezel lights did not come on. Has anyone heard of such a thing or have any idea what I may be experiencing? Any help would be appreciated.

  2. Remove Advertisements
    ClubWRX.net
    Advertisements
     

  3. #2
    Registered User 68sprintb's Avatar
    Join Date
    Dec 2005
    Location
    San Jose, CA
    Posts
    434
    sounds like a bad ground or not fully connected cluster harness, have you tried removing it and putting it back in? if you take it out, look around for wires that don't seem to be going anywhere...
    Blobeye Syndicate #75
    2005 OBP WRX Sport Wagon
    Stewart Warner Boost & Oil temp gauges / OEM 20 mm rear bar
    Cobb stg 2 / STi uppipe / Crucial Racing downpipe
    Stromung 2.5" catless centerpipe / Scooby Sport New Age centre pipe & backbox

  4. #3
    Registered User wrx wagone's Avatar
    Join Date
    May 2005
    Location
    Phillytown, PA
    Posts
    10,775
    Let me ask the obvious stupid question, did you try the dash dimmer on the headlight stalk?
    This message printed on 100% recycled electrons.

+ Reply to Thread

Quick Reply Quick Reply

Register Now

Please enter the name by which you would like to log-in and be known on this site.
If you do not want to register, fill this field only and the name will be used as user name for your post.

Please enter a password for your user account. Note that passwords are case-sensitive.

Please enter a valid email address for yourself. We strongly suggest that you stay away from using aol, yahoo, msn, and hotmail accounts. Sometimes the mail server blocks the emails from our server. As a result you will not receive any notifications including the confirmation email.

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.


Posting Permissions

  • You may post new threads
  • You may post replies
  • You may not post attachments
  • You may not edit your posts
  •