PLS Help: Fog Lights Out
Results 1 to 6 of 6

This is a discussion on PLS Help: Fog Lights Out within the General Maintenance, Troubleshooting & Accidents. forums, part of the Tech & Modifying & General Repairs category; Whats up guys. I ran into a bit of a problem. I tried searching but would not find an answer ...

  1. #1
    Registered User
    Join Date
    Feb 2007
    Posts
    4

    Red face PLS Help: Fog Lights Out

    Whats up guys.

    I ran into a bit of a problem. I tried searching but would not find an answer to resolve the issue.

    I recently changed out my headlights from OEM to black housing ones from ebay. (I just got my WRX last week)

    I changed my turn signal bulbs to some whites from Pep Boys and my headlights to Sylvania Silver Stars.

    I was having an issue with my turn signals hyper blinking so I figured out that one of the bulbs was not tight enough.

    I got that issue resolved, but now I noticed that my foglights arent working at all.

    I tried changing the bulbs, but that didnt help.

    I tried changing the fuses (15).. I grabbed a spare from the main box in the engine and switched it out with the one under the dash.

    I tried making sure all the wires and everything were installed right and in tact.

    Nothing is helping my fog lights turn back on. The fog light button inside wont light up when I press it. I am not sure if that might be the issue. The cruise control lights up Orange but the Fog light doesnt light up at all.

    Any help or suggestions would be very much appreciated.

    Thanks in advance.

  2. Remove Advertisements
    ClubWRX.net
    Advertisements
     

  3. #2
    Registered User bsdiesel's Avatar
    Join Date
    Sep 2006
    Posts
    26

    Problem Resolved?

    Hi, I'm having a similar issue with my 2006 WRX; Fog lights don't turn on, fog light button doesn't light up when pushed, fog light fuse is not blown. Just wondering if you were able to resolve this or if anyone's had the same thing happen to them before. Thanks

    bsd
    2006 Subaru Impreza WRX

  4. #3
    Registered User
    Join Date
    Feb 2007
    Posts
    4
    Hey,

    What was wrong with my car was that the high beams were clicked on, thats why it wouldn't allow my fog lights to come on. I guess its a safety feature that your fog's cant be on at the same time as your high beams.

    Check into that, that's what was wrong with my car.

    Hope this helps, good luck.

    Peace.

  5. #4
    Registered User bsdiesel's Avatar
    Join Date
    Sep 2006
    Posts
    26
    No, my case is different - my high-beams are not on.

    It could be possible that my bulbs are dead, but i find it hard to believe that both would die at the same time. I'd like to know if the fog light button is supposed to light up even if the bulbs are burned out. Does anyone remember when they had a fog light bulb burn out if the button didnt light up?

    bsd
    2006 Subaru Impreza WRX

  6. #5
    Registered User bsdiesel's Avatar
    Join Date
    Sep 2006
    Posts
    26

    solution

    solution: wiring harness was unplugged.

    lesson learned: always check everything after having your car serviced at Barber Subaru in Ventura,CA
    2006 Subaru Impreza WRX

  7. #6
    Registered User
    Join Date
    Feb 2007
    Posts
    4
    Good thing you didnt spend any money trying to fix it.

    Thats retarded, you expect the people at the dealer to do everything right since they are "pro's" and they always seem to mess something up.

    I had alot of issues with my Mitsubishi dealer when i had my 2G but so far the Subaru guys have been good.

    Lets cross our fingers.

    Good to hear your issue is solved!

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •