High Temp Problem
Results 1 to 6 of 6

This is a discussion on High Temp Problem within the General Maintenance, Troubleshooting & Accidents. forums, part of the Tech & Modifying & General Repairs category; I just bought an 04 wrx the other day. I was kinda rippin on it that night and the next ...

  1. #1
    Registered User
    Join Date
    Oct 2006
    Posts
    6

    High Temp Problem

    I just bought an 04 wrx the other day. I was kinda rippin on it that night and the next day i saw coolant was sprayed on the engine bay and realized the dealer had to much coolant in the resivior. I had to go to work so i didnt have time to syphon out so i drove it. On my way to work drivng i noticed the temp guage was fairly high (enough to catch my attention) on the highway. I exit the highway to a residential street to bout 40 and then it hits red. So i pull over and let er cool down enough to make it to work.

    Coolant is clean
    Could there be air bubbles?

  2. Remove Advertisements
    ClubWRX.net
    Advertisements
     

  3. #2
    Registered User rr1911's Avatar
    Join Date
    Nov 2005
    Location
    Central Florida
    Posts
    0
    probably bubbles... squeez the lines and see if it stops... also could be a bad termostat... if anything take it back to the dealership
    Army Ranger For Life ! Thin Blue Line
    Military Militia # 1911/ Blobeye Syndicate # 1911/ Modifier's Anonymous # 1911/ Hawk-Eye Alliance # 1911
    All We'll Drive
    DIFFERENT STROKES
    EVEN MY DENTIST TOLD ME FLOSS 7 DAYS A WEEK
    POST WH0RE KING

  4. #3
    Registered User
    Join Date
    Oct 2006
    Posts
    6
    Thanks for your help

  5. #4
    Registered User Thug Nasty's Avatar
    Join Date
    Jul 2006
    Location
    Denver CO / Portland OR
    Posts
    185
    Probably bubbles. Search for burping the system if you don't know how to get the bubbles out. Let us know how it works out!
    -John
    Different Strokes
    Dirty Crew #2002
    Mods in profile.

  6. #5
    Registered User
    Join Date
    Oct 2006
    Posts
    6
    I tried burpin the system and that didnt help but i took it in to the dealer today to have them look at it. I talked to few other people and they said the thermostat is bad.

  7. #6
    Registered User
    Join Date
    Oct 2006
    Posts
    6
    The thermostat was stuck closed. Dealer replaced it and now the rex is ready to roll

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •