my subbie is running like shat
+ Reply to Thread
Results 1 to 10 of 10

This is a discussion on my subbie is running like shat within the General Maintenance, Troubleshooting & Accidents. forums, part of the Tech & Modifying & General Repairs category; im just bought my wrx about a month ago and recently its been 20 below and my car is running ...

  1. #1
    Registered User
    Join Date
    Jan 2007
    Location
    marquette mi
    Posts
    10

    my subbie is running like shat

    im just bought my wrx about a month ago and recently its been 20 below
    and my car is running like ****... the clutch is so stiff it feels like im pushing a cinder block uphill with my foot.. not only that the pedal rebounds so slow and the clutch at some points is not even engaging... this is after letting the car warm up for about 30 mins as well the motor has a lot louder chatter or light nocking than normally has any one have some tips... as well the dealer ship is not sounding to cool about it as well when i called to talk to them about it they told me to simply not drive it when its cold but i dont have any other vehicle to drive... and from a car dealership thats not a very god comment to be saying ... just drive something else?... any ways any one know how i can light a fire under the dealers ass to take care of this because they arnt handleing my problem very seriously..
    Anthony

  2. Remove Advertisements
    ClubWRX.net
    Advertisements
     

  3. #2
    Registered User
    Join Date
    Mar 2003
    Location
    tacoma
    Posts
    656
    uh if its under warranty then take it back there and have them fix it, if not the dealer is not responsible for the car after its been sold.

  4. #3
    Registered User bcyb1029's Avatar
    Join Date
    Feb 2006
    Location
    Chicago
    Posts
    3,021
    Its -4 here and mine sux to drive to, it is so hard too get in gear and press the clutch. I think it is just the cold.
    Tuned by Jorge at P&L, 240.83whp 239.60wtq at 14.8psi on 2.0L with stock td04 (But doesn't run)

  5. #4
    Registered User
    Join Date
    Jan 2007
    Location
    marquette mi
    Posts
    10
    it is under waranty but when i asked them for an apointment they told me to just drive somthing else when its cold

  6. #5
    Registered User
    Join Date
    Oct 2006
    Posts
    642
    did you tell them you dont have anything else to drive? make them give you a rental or something

  7. #6
    Registered User
    Join Date
    Oct 2006
    Posts
    275
    If it's under warranty you should at the very least be able to take it in. Just don't take no for answer. You might have to pay for an appointment but at least then they're required to look at your car. My car is an automatic and it too doesn't like to drive great in the cold, and when I say cold I'm only talkin like 35. I think if you give the car a few minutes to heat up before you start driving it you might do a little better.

    Try starting the car like 3-5 minutes before you are actually leaving in the morning / night and that will get things flowing. As far as an engine knocking... are you using the correct octane gas?

  8. #7
    Registered User cfvt17's Avatar
    Join Date
    Jan 2007
    Location
    Burlington, VT
    Posts
    18
    fyi i believe he posted that he lets it warm up ~30 min. before driving

    Quote Originally Posted by ww_Crimson View Post

    Try starting the car like 3-5 minutes before you are actually leaving in the morning / night and that will get things flowing.
    New England F4

    vermont...anyone? hahaha...

  9. #8
    Registered User dbrunone's Avatar
    Join Date
    Nov 2006
    Posts
    109
    Do you have to use different trans fluid when its really cold out? Maybe something with a higher viscosity at low temps? I dunno, it just sounds like the fluid in there is too thick to let anything move. As for engine....same thing...it could be clattering cause the oil isnt thin enough to be pumped up to the valves and things. I dunno just a guess.

  10. #9
    Registered User
    Join Date
    Jan 2007
    Location
    marquette mi
    Posts
    10
    well i have a warranty appointment for friday... like previously stated they are going to make me pay for the appointment... but hopefully they find my clutch is shot from the 4 days of driving in this... my gears grind like hell when i shift because the clutch is not engaging... there going to drop my tranny and have a peak at the clutch and trans... could not talk them into taking a peak at the motor though they said its normal for the motor to have a slight nock and chatter... oh well i havent abused it once so they are not going to find any signs of abuse overall badd expierience with subaru how ever... soa better not refuse any warrenty...

  11. #10
    Registered User
    Join Date
    May 2006
    Posts
    0
    I live in colorado and its been rly cold latley and my wrx has the same problem untill it warms up and you start driveing it for a few minutes to get all your fluids warmed up and moveing through the car.

+ Reply to Thread

Quick Reply Quick Reply

Register Now

Please enter the name by which you would like to log-in and be known on this site.
If you do not want to register, fill this field only and the name will be used as user name for your post.

Please enter a password for your user account. Note that passwords are case-sensitive.

Please enter a valid email address for yourself. We strongly suggest that you stay away from using aol, yahoo, msn, and hotmail accounts. Sometimes the mail server blocks the emails from our server. As a result you will not receive any notifications including the confirmation email.

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.


Posting Permissions

  • You may post new threads
  • You may post replies
  • You may not post attachments
  • You may not edit your posts
  •