mbc removed: Only running 7psi!?
Results 1 to 4 of 4

This is a discussion on mbc removed: Only running 7psi!? within the General Maintenance, Troubleshooting & Accidents. forums, part of the Tech & Modifying & General Repairs category; so i got a hallman mbc and installed it ran 15psi....so the problem is that i decided to take it ...

  1. #1
    Registered User DUBAURX's Avatar
    Join Date
    Feb 2006
    Location
    Tracy,CA
    Posts
    40

    mbc removed: Only running 7psi!?

    so i got a hallman mbc and installed it ran 15psi....so the problem is that i decided to take it off and run with the stock solenoid and i only ran 7psi! can anyone tell me what is wrong

  2. Remove Advertisements
    ClubWRX.net
    Advertisements
     

  3. #2
    Banned
    Join Date
    Jan 2007
    Location
    Broomfield, CO
    Posts
    140
    You either hooked something up wrong, or you have lost eh restrictor pill.

  4. #3
    Registered User
    Join Date
    Feb 2004
    Location
    Evansville, IN
    Posts
    3,733
    Quote Originally Posted by WRXpimp View Post
    You either hooked something up wrong, or you have lost eh restrictor pill.
    exactly...
    1988 Celica Alltrac
    Hallman Pro, 15x7.5 +20mm Rota Slipstreams
    2005 LGT 315whp/340wtq@21psi - Sold
    VF52, Crucial P&P&C Manifolds, UP, DP, RP, Magnaflow CBE, Hallman PRO, ROMRaider
    2003 WRX 371whp/355wtq@24psi - Sold
    TD05H-20G-38mm Tial, Meth Injection, Hyperflow TMIC, ROMRaider
    Dyno Chart METH vs 93 oct

  5. #4
    Registered User
    Join Date
    Nov 2006
    Posts
    28
    same problem... you have to replace the soliniod vaccum line to one with a pill in it. their like 15 bucks at the dealship

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •