Uh oh. Does this mean a fuse is blown? Help!
Results 1 to 7 of 7

This is a discussion on Uh oh. Does this mean a fuse is blown? Help! within the General Maintenance, Troubleshooting & Accidents. forums, part of the Tech & Modifying & General Repairs category; OK so I'm not particularly electronically tech savvy, but something is fishy with my 03 WRX. I could have sworn ...

  1. #1
    Moderator WilliamG's Avatar
    Join Date
    Nov 2002
    Location
    Seattle, WA
    Posts
    1,215
    I Support ClubWRX

    Uh oh. Does this mean a fuse is blown? Help!

    OK so I'm not particularly electronically tech savvy, but something is fishy with my 03 WRX.

    I could have sworn that when I turned my headlights on, my cruise control button lit up. It no longer does (if it did). Also, I noticed that my fog-light button no longer lights up (and it definitely used to!). The strange thing is that when I push the cruise control button, the orange part lights up, and when I push the fog-light button, the green line lights up.

    Is there a fuse or something that could have gone which actually lights the buttons up when you turn the headlights on?

    Thanks in advance for any help you can offer.
    2010 SSM STI

  2. Remove Advertisements
    ClubWRX.net
    Advertisements
     

  3. #2
    Registered User Jje121's Avatar
    Join Date
    Jan 2005
    Location
    Fitchburg, ma
    Posts
    0
    Quote Originally Posted by WilliamG View Post
    OK so I'm not particularly electronically tech savvy, but something is fishy with my 03 WRX.

    I could have sworn that when I turned my headlights on, my cruise control button lit up. It no longer does (if it did). Also, I noticed that my fog-light button no longer lights up (and it definitely used to!). The strange thing is that when I push the cruise control button, the orange part lights up, and when I push the fog-light button, the green line lights up.

    Is there a fuse or something that could have gone which actually lights the buttons up when you turn the headlights on?

    Thanks in advance for any help you can offer.
    I don't think that mine light up.
    New England F4
    Bugeye Mafia
    2004 GMC Sierra 1500
    03 Subaru WRX (SOLD)
    01 CBR 929 (SOLD)
    Quote Originally Posted by blarg
    nothing funny about stubble on the man-marbles.

  4. #3
    Registered User Thug Nasty's Avatar
    Join Date
    Jul 2006
    Location
    Denver CO / Portland OR
    Posts
    185
    Mine don't light up either except when you press them.
    -John
    Different Strokes
    Dirty Crew #2002
    Mods in profile.

  5. #4
    Moderator WilliamG's Avatar
    Join Date
    Nov 2002
    Location
    Seattle, WA
    Posts
    1,215
    I Support ClubWRX
    Quote Originally Posted by Thug Nasty View Post
    Mine don't light up either except when you press them.
    Are you guys serious? I know for SURE that my fog-light button to the left of the steering wheel definitely lit up when I turned my headlights on!
    2010 SSM STI

  6. #5
    Registered User
    Join Date
    Dec 2002
    Posts
    4
    i believe you are talking about the writing on the controls, if it did used to light up then the illumination bulbs are probably just blown and need to be replaced. its only small light bulbs that light up the background

  7. #6
    Registered User Sundawg's Avatar
    Join Date
    Mar 2007
    Location
    Omaha NE
    Posts
    40
    There is a good tutorial at scoobymods that tells you how to replace the bulbs. I had a bad one for the foglights when I bought the car, and fixed it with a $2 part from Radio Shack.

    Here's the link:
    http://www.scoobymods.com/forums/showthread.php?t=3582

  8. #7
    Moderator WilliamG's Avatar
    Join Date
    Nov 2002
    Location
    Seattle, WA
    Posts
    1,215
    I Support ClubWRX
    Thanks for the information! Appreciated.
    2010 SSM STI

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •