Misfire on cylinder 2, bad coil pack?
+ Reply to Thread
Results 1 to 12 of 12

This is a discussion on Misfire on cylinder 2, bad coil pack? within the General Maintenance, Troubleshooting & Accidents. forums, part of the Tech & Modifying & General Repairs category; hey guys need some help. i replaced the plugs on my '02 wrx and all the sudden started geting a ...

  1. #1
    Registered User
    Join Date
    Feb 2006
    Posts
    21

    Misfire on cylinder 2, bad coil pack?

    hey guys need some help. i replaced the plugs on my '02 wrx and all the sudden started geting a blinking CEL. took it and got the codes pulled and it showed misfire on cylinder 2. the guy suggested plugs so i bought a whole new set and replaced them all with hopes that i had just gotten a bad plug but still getting the misfire. the CEL stays on and then blinks like 15 times and returnes the solid. doesn't seem to matter if i rev it up high or just idle it still misfires. car seems to run "ok" but idles a bit rough. so could this be the coil pack on cylinder number 2 and if so, which cylinder is number 2 and is there any way to test the pack before i spend $120 on a new one.

    i don't have many mods but here they are:
    Perrin uppipe and downpipe
    short ram intake
    boost control set at 15psi

  2. Remove Advertisements
    ClubWRX.net
    Advertisements
     

  3. #2
    Registered User neener's Avatar
    Join Date
    May 2006
    Location
    WA
    Posts
    311
    WOW, its like deja vu. yep its the coil pack i just got my car back like a week ago from this, it sat in my drive way for like 5 days i was devastated but anyways yes your gonna need to change the coil pack and i think the cyl #2 is the one closest to the driver, i was told that they are labeled on the block but i never saw anything. btw i just decided to change out all 4 and im out of warranty so that was no fun at all.
    un poqito.

    Quote Originally Posted by ninefourteener View Post
    Personally..... I like to do full-throttle powershifts in my car.... just leave the gas on the floor.. stomp the clutch, throw the shifter, and hold on.
    I also like to scream at 7000RPMs in 1st gear...... and them slam it into reverse, sidestep the clutch, and do backwards 4-wheel burnouts while still moving forward.
    It's fun... try it

  4. #3
    Registered User
    Join Date
    Feb 2006
    Posts
    21
    awsome i ordered 1 coil pack. don't have the funds to replace all right now

    thanx for the help man, i too am devistated

  5. #4
    Registered User
    Join Date
    Feb 2006
    Posts
    21
    ok so i installed the new coil pack and everything seemed to be fine for about 20 minutes then i started getting a blinking cel again. took it and got the codes pulled and it's misfire on cylinder 2 and cylinder 4 now. any ideas guys?
    i replaced the pack on number 2 but it's still misfiring for some reason. the car seems to go pretty good still and it's not idling rough anymore. any help or input would be great.

  6. #5
    Administrator Trainrex's Avatar
    Join Date
    May 2003
    Posts
    26,593
    I Support ClubWRX
    Do a compression test.

  7. #6
    Registered User
    Join Date
    Feb 2006
    Posts
    21
    well did the compression test and found the problem.

    cylinder #1- 140
    cylinder #2- 35
    Cylinder #3- 140
    cylinder #4- 140

    it appears cylinder #2 is dead. the rings must be shot

  8. #7
    Administrator Trainrex's Avatar
    Join Date
    May 2003
    Posts
    26,593
    I Support ClubWRX
    Quote Originally Posted by generaltesla View Post
    well did the compression test and found the problem.

    cylinder #1- 140
    cylinder #2- 35
    Cylinder #3- 140
    cylinder #4- 140

    it appears cylinder #2 is dead. the rings must be shot
    I was hoping I was wrong.

  9. #8
    Registered User
    Join Date
    Feb 2006
    Posts
    21
    is 140 ok for the other cylinders?

  10. #9
    Administrator Trainrex's Avatar
    Join Date
    May 2003
    Posts
    26,593
    I Support ClubWRX
    Quote Originally Posted by generaltesla View Post
    is 140 ok for the other cylinders?
    Yes.

  11. #10
    Registered User
    Join Date
    Feb 2006
    Posts
    21
    well it's at the dealship now, i got the extended warrenty whith the car so it should be covered.

  12. #11
    Registered User
    Join Date
    Feb 2006
    Posts
    21
    well heard back from the dealership, looks like the piston got cracked or broke and it scored up the cylinder wall pretty good so they are putting a new short block in it. any ideas how a piston just "breaks" ?

  13. #12
    Administrator Trainrex's Avatar
    Join Date
    May 2003
    Posts
    26,593
    I Support ClubWRX
    Quote Originally Posted by generaltesla View Post
    well heard back from the dealership, looks like the piston got cracked or broke and it scored up the cylinder wall pretty good so they are putting a new short block in it. any ideas how a piston just "breaks" ?
    Using a boost controller without any engine management.

+ Reply to Thread

Quick Reply Quick Reply

Register Now

Please enter the name by which you would like to log-in and be known on this site.
If you do not want to register, fill this field only and the name will be used as user name for your post.

Please enter a password for your user account. Note that passwords are case-sensitive.

Please enter a valid email address for yourself. We strongly suggest that you stay away from using aol, yahoo, msn, and hotmail accounts. Sometimes the mail server blocks the emails from our server. As a result you will not receive any notifications including the confirmation email.

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.


Posting Permissions

  • You may post new threads
  • You may post replies
  • You may not post attachments
  • You may not edit your posts
  •