screehing sound
Results 1 to 4 of 4

This is a discussion on screehing sound within the General Maintenance, Troubleshooting & Accidents. forums, part of the Tech & Modifying & General Repairs category; hello i have a 04 sti and 2 days ago i started getting this screeching sound right after i installed ...

  1. #1
    Registered User wickedevillas's Avatar
    Join Date
    Nov 2006
    Posts
    38

    screehing sound

    hello i have a 04 sti and 2 days ago i started getting this screeching sound right after i installed my new tires. at first i tought it could be the tires but im not sure what it is because it seems to becoming out of the engine. seems like it starts at 4grpm all the way up when im in boost at lower rpms i cant really hear anything. i checked the lines for vacuum leaks and everything seems tight im stumped on this. I have 25k miles on it.

  2. Remove Advertisements
    ClubWRX.net
    Advertisements
     

  3. #2
    Administrator Trainrex's Avatar
    Join Date
    May 2003
    Posts
    26,590
    I Support ClubWRX
    Sounds like an uppipe leak.

  4. #3
    Registered User wickedevillas's Avatar
    Join Date
    Nov 2006
    Posts
    38
    yea thats what i was thinking well i will take it to the dealership and ill see what they say. any idea on the labor?

  5. #4
    Registered User wickedevillas's Avatar
    Join Date
    Nov 2006
    Posts
    38
    Good news i figured out the problem it was a up pipe leak =) one of the clamps on it became loss and actually layed on the turbo. clamped it back up and i realized i was losing a lot of boost.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •