baffled by location of restrictor pill...
+ Reply to Thread
Results 1 to 10 of 10

This is a discussion on baffled by location of restrictor pill... within the General Maintenance, Troubleshooting & Accidents. forums, part of the Tech & Modifying & General Repairs category; since I got my car, I've noticed the location of the brass restrictor pill is on the wastegate acctuator side ...

  1. #1
    Registered User tsignr's Avatar
    Join Date
    Aug 2006
    Location
    Billings, MT
    Posts
    155

    baffled by location of restrictor pill...

    since I got my car, I've noticed the location of the brass restrictor pill is on the wastegate acctuator side of the "T". Boost is normal, perhaps a little low. When I reverse the "T", so that the restrictor pill is nearest the turbo outlet, it will overboost in 2nd. I have no 3/16" mod and the wastegate is backed off all the way. Could this be caused by the wastegate/boost solenoid?

  2. Remove Advertisements
    ClubWRX.net
    Advertisements
     

  3. #2
    Administrator Trainrex's Avatar
    Join Date
    May 2003
    Posts
    26,593
    I Support ClubWRX
    The brass pill should be on the compressor side. Have the wastegate hoses been changed?

  4. #3
    Registered User tsignr's Avatar
    Join Date
    Aug 2006
    Location
    Billings, MT
    Posts
    155
    Quote Originally Posted by Trainrex View Post
    The brass pill should be on the compressor side. Have the wastegate hoses been changed?
    I know, that's my dilemna. And no, everything appears to be factory.

  5. #4
    Administrator Trainrex's Avatar
    Join Date
    May 2003
    Posts
    26,593
    I Support ClubWRX
    Normally a faulty FBC will cause low boost. What mods are you running?

  6. #5
    Registered User tsignr's Avatar
    Join Date
    Aug 2006
    Location
    Billings, MT
    Posts
    155
    Quote Originally Posted by Trainrex View Post
    Normally a faulty FBC will cause low boost. What mods are you running?
    hks downpipe(I know, it sucks), perrin flat panel intake, perrin pulley and cobb access port stage 2.

  7. #6
    Administrator Trainrex's Avatar
    Join Date
    May 2003
    Posts
    26,593
    I Support ClubWRX
    Quote Originally Posted by tsignr View Post
    hks downpipe(I know, it sucks), perrin flat panel intake, perrin pulley and cobb access port stage 2.
    With a stock turbo, that downpipe is just fine.

    Have you tried putting the pill in the correct position, and resetting the ECU?

  8. #7
    Registered User tsignr's Avatar
    Join Date
    Aug 2006
    Location
    Billings, MT
    Posts
    155
    Quote Originally Posted by Trainrex View Post
    With a stock turbo, that downpipe is just fine.

    Have you tried putting the pill in the correct position, and resetting the ECU?
    I have, I even made sure that the pill was set right and I could see through the hose and the pill itself. What else keeps the car from overboosting that might not be doing it's job?

  9. #8
    Administrator Trainrex's Avatar
    Join Date
    May 2003
    Posts
    26,593
    I Support ClubWRX
    Quote Originally Posted by tsignr View Post
    I have, I even made sure that the pill was set right and I could see through the hose and the pill itself. What else keeps the car from overboosting that might not be doing it's job?
    Possibly a stuck wastegate. When you undo the wastegate arm, does it move freely?

  10. #9
    Registered User tsignr's Avatar
    Join Date
    Aug 2006
    Location
    Billings, MT
    Posts
    155
    Quote Originally Posted by Trainrex View Post
    Possibly a stuck wastegate. When you undo the wastegate arm, does it move freely?
    I could check it again. What should it do? Should it be loose or stiff? Could it be stuck closed?

    Thanks for all the help by the way. I haven't found any posts w/ this particular problem.

  11. #10
    Administrator Trainrex's Avatar
    Join Date
    May 2003
    Posts
    26,593
    I Support ClubWRX
    Quote Originally Posted by tsignr View Post
    I could check it again. What should it do? Should it be loose or stiff? Could it be stuck closed?

    Thanks for all the help by the way. I haven't found any posts w/ this particular problem.
    It could be stuck closed. When you detach it from the arm it should move freely.

+ Reply to Thread

Quick Reply Quick Reply

Register Now

Please enter the name by which you would like to log-in and be known on this site.
If you do not want to register, fill this field only and the name will be used as user name for your post.

Please enter a password for your user account. Note that passwords are case-sensitive.

Please enter a valid email address for yourself. We strongly suggest that you stay away from using aol, yahoo, msn, and hotmail accounts. Sometimes the mail server blocks the emails from our server. As a result you will not receive any notifications including the confirmation email.

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.


Posting Permissions

  • You may post new threads
  • You may post replies
  • You may not post attachments
  • You may not edit your posts
  •