2007 Clutch Squeak.. ridiculous
Page 1 of 2 12 LastLast
Results 1 to 15 of 17

This is a discussion on 2007 Clutch Squeak.. ridiculous within the General Maintenance, Troubleshooting & Accidents. forums, part of the Tech & Modifying & General Repairs category; I know this topic has been covered before, but I just wanted to re-hash the issue since it seems to ...

  1. #1
    Registered User smash's Avatar
    Join Date
    Nov 2006
    Location
    Ashburn, VA
    Posts
    37

    2007 Clutch Squeak.. ridiculous

    I know this topic has been covered before, but I just wanted to re-hash the issue since it seems to be haunting the '07 models as well... just purchased my '07 OBP WRX on November 24th. I have been following the break-in period rules, and only have 625 miles on the car. I began noticing a slight squeak from the clutch at about 200 miles. Now it is incessant and even more noticeable when its really cold out (yes, I realize the cold/heat affect it..). I've had the car to the dealer 2 times now, about to be a third.. both times they have simply told me "we did not notice any abnormal noises coming from the clutch". Huh? How do you figure? This squeaking is driving me freaking NUTS. I am going in there next week to have my turbo gauge re-installed (because they bent the first one, my dealer is a bunch of idiots) and I am going to INSIST that they lube the clutch. I almost feel like I'm getting ****ed over because I'm a girl and dealers assume girls don't know a car from a monkey riding a tricycle.

    I had a Scion tC for awhile and had the same problem during the first 30k miles, dealer lubed the clutch 2 or 3 times and it eventually went away.

    So I pose this question.. I absolutely ADORE my car, my first Subaru ever, my first AWD car ever and I wouldn't trade it for the world.. but is this obnoxious squeak something I am going to have to look forward to for the duration of the time I own my car? Or will perpetual lubing help it? Is there a way (and what exactly do I use) to lube it myself? Should I even be worried, or just learn to ignore the noise?

  2. Remove Advertisements
    ClubWRX.net
    Advertisements
     

  3. #2
    Registered User motormike's Avatar
    Join Date
    Dec 2006
    Posts
    140
    make sure its not the clutch pedal mounting bracket...it could just be the heat/cold changes that cause firewall flex, thats when you depress
    the pedal and the metal fatigues and hairline cracks can make
    annoying squeaking sounds when the pedal is depressed...an '07 though? shouldn't be happening...if it worsens could be linkage? who knows, a number of things
    **** off with your candy paint jobs and spoilers that are 8x too big , I say never be complete, I say stop being perfect, I say let... lets evolve, let the chips fall where they may.

  4. #3
    GraysonSubaru's Avatar
    Join Date
    May 2005
    Location
    Knoxville, TN
    Posts
    4,686
    dumb question, but thought id ask:

    are you sure the squeaking isnt your shoe on the pedal itself that is squeaking?
    Quote Originally Posted by RayfieldsWRX View Post
    Hey, being the forum car ADD guy is better than being the forum OG.
    Quote Originally Posted by Mikie13 View Post
    Well nobody cares what you think, Seth

  5. #4
    Registered User smash's Avatar
    Join Date
    Nov 2006
    Location
    Ashburn, VA
    Posts
    37
    yea, I'm sure its not my shoes .. I drive with flip-flops mostly

    Should I tell the dealer to look at the clutch pedal mounting bracket? They've looked at it twice, or so they tell me, and can't find anything wrong with it.

  6. #5
    Registered User motormike's Avatar
    Join Date
    Dec 2006
    Posts
    140
    Quote Originally Posted by smash View Post
    yea, I'm sure its not my shoes .. I drive with flip-flops mostly

    Should I tell the dealer to look at the clutch pedal mounting bracket? They've looked at it twice, or so they tell me, and can't find anything wrong with it.
    just a stiff clutch, i dont think theres too much they can do, its not a "mechanical" problem...if they say theres nothing wrong time after time, what could it be?

    take it to a transmission specialist, not some local mechanic, and ask them....they prob. experience that problem 10x a week

    and dont wear squeaky shoes, flip flops you say? perhaps wet from the beach?... just kidding
    **** off with your candy paint jobs and spoilers that are 8x too big , I say never be complete, I say stop being perfect, I say let... lets evolve, let the chips fall where they may.

  7. #6
    Registered User Leftlane's Avatar
    Join Date
    Dec 2006
    Posts
    11
    Got an '06 WRX TR with just under 6k miles that suffers what I think is the same problem you describe. I did some quick searches and couldn't quite find the issue, but probably out here somewhere. So this is essentially a "me too" post, sorry.

    It's a faint "eeek" noise that occurs when I put the clutch in. Doesn't appear to be too temp driven by my observsations, but then again weather here is fairly mild. I took it to the dealer. They drove it and stated they couldn't reproduce the problem. I'm guessing the technician spent too much time near the big speakers at the <loud-band-of-your-choice> concert since you'd kinda need to be able to hear the upper MHz range to pick up this noise. It drives me ape when I pay attention to it, but it's subtle enough to ignore on most days.

    I tried spreading some white lithium grease up under the dash on the clutch pivot, but that didn't seem to help.

  8. #7
    Registered User mikehoyer's Avatar
    Join Date
    Dec 2006
    Location
    West Chester, PA
    Posts
    64
    +1 on the clutch squeek. It just started happening on my 06 maybe a month ago (12K miles). I only hear it when I put the clutch all the way in to the floor.

    My car's other moans and groans:

    My driver side window is making a "grrrrrrrrrrrrrrrrrrr" noise when it goes up or down.

    Rattle from under the clock

    Boost gauge rattle

  9. #8
    Registered User motormike's Avatar
    Join Date
    Dec 2006
    Posts
    140
    i guess your goin to have to deal with it...WRXs are not luxury sedans with sound proofing and damering...its a light-weight sports car with stiff suspension,

    as far as the clutch squeek is concerend, ill try to dig something up, your just going to need to grease different moving part to see what it really is, trial and error...if soemone figures it out, please post it, maybe make a DIY tutorial
    Last edited by motormike; 12-14-2006 at 07:02 PM.
    **** off with your candy paint jobs and spoilers that are 8x too big , I say never be complete, I say stop being perfect, I say let... lets evolve, let the chips fall where they may.

  10. #9
    Registered User smash's Avatar
    Join Date
    Nov 2006
    Location
    Ashburn, VA
    Posts
    37
    yeah.. that sounds like a plan. I mean, I guess it's not so much the noise that's bothering me, moreso I'm worried that it may be alluding to some type of problem or failure with the clutch (but I doubt it).. so for now.. I will learn to live with it
    2007 OBP WRX - Girls <3 fast cars too

  11. #10
    Registered User
    Join Date
    Oct 2006
    Location
    Glenview IL
    Posts
    256
    Wow, I had the same problem that started at about 200 miles as well.
    Took it back to the dealer and they inspected it all without a problem and lubed everything up. Took care of the problem. Ill find the paperwork to see what exactly was wrong and let you know.
    Hawk-Eye #009
    Dont let the SN fool you, my car is black.

  12. #11
    Registered User smash's Avatar
    Join Date
    Nov 2006
    Location
    Ashburn, VA
    Posts
    37
    Cool.. I'd appreciate it. I just sent my dealer a nastygram telling them to lube the effing clutch and that I am pissed because I've had it in there twice and it could've been lubed already. Stohlman is absolutely worthless.
    2007 OBP WRX - Girls <3 fast cars too

  13. #12
    Registered User
    Join Date
    Sep 2006
    Posts
    2
    i've had my 06 sti clutch lubed at the dealer and it still squeaks...
    my fault tho cuz i had burnt it at a stop on a crazy incline.

  14. #13
    Registered User
    Join Date
    Oct 2005
    Location
    long island
    Posts
    605
    Is the actual clutch squeaking, or is just the pedal squeaking when depressing it. I have a squeaky pedal in my 06. It's been like that since the day I picked the car up from the dealer.
    06-wrx: stage 2 and loving every minute of it!

  15. #14
    Registered User StylesJim's Avatar
    Join Date
    Dec 2006
    Location
    Sterling, VA
    Posts
    25
    Smash, you talking about the dealer in Tysons/Mclean VA? If so, try and give Dulles Auto in Leesburg VA a call. I picked mine up there and the shop manager has been nothing but helpful. Never called about a clutch issue, but I am sure they would be willing to help. I have heard from a few places that Stohlman is a pain.

  16. #15
    Registered User blackzwrx's Avatar
    Join Date
    Dec 2006
    Location
    Was Philly, now D-town
    Posts
    480
    It's the clutch slave cylinder pushing against the clutch fork. I had it on many of my cars, and Z-cars that come into my work. The slave clyinder is under your I/C on top of your trans, kinda off to the drivers side a bit. You can either remove your I/C and lube it with some WD40 that way, Or you can lay under your car and do it. Either way it's a pretty clear shot, and that should solve your problem. You want to lube where the slave cylinder meets the clutch fork. It's pretty easy to find. It's a metal peice that has a brake line going into it, with a bleeder screw, and a rubber accordian dust boost. It's pushing against a fork that goes inside the trans. Hope that helps.

Page 1 of 2 12 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •