Code issues
Results 1 to 7 of 7

This is a discussion on Code issues within the General Maintenance, Troubleshooting & Accidents. forums, part of the Tech & Modifying & General Repairs category; I'm throwing code p0037. By reading what other says it just an emission code. But I'm experiencing Engine Stuttering. When ...

  1. #1
    Registered User hakira's Avatar
    Join Date
    May 2004
    Location
    Slidell, La
    Posts
    413

    Code issues

    I'm throwing code p0037. By reading what other says it just an emission code. But I'm experiencing Engine Stuttering. When I clear the code It runs great, responsive and smooth. But Once I turn off the car and restart it, the code is back and causing the engine stuttering.

    The only other code I'm throwing is AC refrigent very low.

    Any suggestions?
    02' WRX OSECUROM STG 2 93OCT on 91OCT map -13.708 SEC / 097.84 MPH / 1.86 60 ft @ No Problem Raceway

    02' WRX OSECUROM STG 2.5 93OCT- 12.9 SEC @ No Problem Raceway
    Mods

  2. Remove Advertisements
    ClubWRX.net
    Advertisements
     

  3. #2
    Registered User
    Join Date
    Aug 2005
    Location
    Winchester Virginia
    Posts
    70
    hey bro im havin the exact same issue..... istart to stutter at around 5600k and up.... i have no idea wat it is.. my boost is fine the vaccuum is fine and the fuel filter is clean... and i even changed my spark plugs... im clueless at the moment...

  4. #3
    Registered User D0WNxSH1FT's Avatar
    Join Date
    Oct 2004
    Location
    Westchester Cnty, NY
    Posts
    6,545
    One, stop clearning codes. You need to diagnose the issue, not just turn the light off.

    P0037 = Rear oxygen sensor heater circuit malfunction

    You might need to replace the sensor since your car is getting older.
    2008 Satin White Pearl WRX Sedan w/ Navi
    2005 San Remo Red WRX Sedan w/ VF34 (traded)
    Pi Kappa Alpha | New England Flat 4

  5. #4
    Registered User VVVV's Avatar
    Join Date
    Sep 2003
    Location
    Denverish
    Posts
    1,311
    The good news is that's the cheap O2 sensor. The bad news is that the rear O2 sensor does not control operation, so the stuttering is likely not being caused by the bad rear sensor.

    More info please. UTEC logs? Any other pending codes? Any recent work done or changes? It kind of sounds like the car is pulling timing. Bad gas?

  6. #5
    Registered User D0WNxSH1FT's Avatar
    Join Date
    Oct 2004
    Location
    Westchester Cnty, NY
    Posts
    6,545
    Quote Originally Posted by VVVV View Post
    More info please. UTEC logs? Any other pending codes? Any recent work done or changes? It kind of sounds like the car is pulling timing. Bad gas?
    +1 I thought it might be the new winter gas that everyone is starting to get. But then, ive never had a cel (**knocks on a freaking red wood**) misfire for winter gas.
    2008 Satin White Pearl WRX Sedan w/ Navi
    2005 San Remo Red WRX Sedan w/ VF34 (traded)
    Pi Kappa Alpha | New England Flat 4

  7. #6
    He simply abides. SD_GR's Avatar
    Join Date
    Jul 2002
    Location
    CA, US
    Posts
    22,574
    I Support ClubWRX
    Quote Originally Posted by D0WNxSH1FT View Post
    +1 I thought it might be the new winter gas that everyone is starting to get. But then, ive never had a cel (**knocks on a freaking red wood**) misfire for winter gas.
    The original poster is in DE not US though, right?
    WRX Info Links, Courtesy TheJ
    The world breaks everyone and afterward many are strong in the broken places. Ernest Hemingway
    I lied. I cheated. I bribed men to cover the crimes of other men. I am an accessory to murder. But the most damning thing of all... I think I can live with it. And if I had to do it all over again - I would. Benjamin Sisko
    DISCLAIMER: Opinions expressed are the author's alone and are inherently worthless.

  8. #7
    Registered User hakira's Avatar
    Join Date
    May 2004
    Location
    Slidell, La
    Posts
    413
    One, stop clearning codes. You need to diagnose the issue, not just turn the light off.
    One, I'm not that retarded. Right after I posted this, I ordered another rear O2 Sensor.

    More info please. UTEC logs? Any other pending codes? Any recent work done or changes? It kind of sounds like the car is pulling timing. Bad gas?
    -I'm awaiting for installtion hardware from TurboXS for like 2 weeks now so no logging. I'm just going with Enginuity Tuning now anyways (just waiting on tactrix cable)
    -Like I said in my post only other code I'm pulling is AC refrigerant very low (don't remember exact code number). The P0037 is under Stored and Pending codes.
    -Recently installed PLX M300, IC hoses and PWR TMIC. Now I talked a buddy of mine who said that the TMIC should be fine to drive casual w/o tuning, while I waited for my hardware. I kinda thought this what might of caused the stuttering but I assumed the ECU should be able to adjust for the change.

    The original poster is in DE not US though, right?
    Yes I live in Germany.
    02' WRX OSECUROM STG 2 93OCT on 91OCT map -13.708 SEC / 097.84 MPH / 1.86 60 ft @ No Problem Raceway

    02' WRX OSECUROM STG 2.5 93OCT- 12.9 SEC @ No Problem Raceway
    Mods

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •