Rough idle
Results 1 to 4 of 4

This is a discussion on Rough idle within the General Maintenance, Troubleshooting & Accidents. forums, part of the Tech & Modifying & General Repairs category; when the fan on the radiator or the a/c compressor kicks on the idle starts to die and then, I ...

  1. #1
    Registered User Blue_Eyez_'s Avatar
    Join Date
    Mar 2006
    Location
    Birmingham, AL
    Posts
    197

    Rough idle

    when the fan on the radiator or the a/c compressor kicks on the idle starts to die and then, I guess to keep the car from cutting off, it rev's to about 1500rpm, then down to almost dead, back to 1300, so on until the fan or compressor shuts off.

    My brother said it sounds like a vacuum leak? idk crap about working on cars...just thought I would ask you guys before I have to break down and take it to the dealer.
    HAWK-EYE ALLIANCE #44
    2006 SGM WRX
    Cobb Stage 2
    APS 3" Catted TBE
    H-Tech Springs
    Eibach 10mm Spacers

  2. Remove Advertisements
    ClubWRX.net
    Advertisements
     

  3. #2
    Registered User 06grayrex's Avatar
    Join Date
    Mar 2006
    Location
    STL
    Posts
    379
    Quote Originally Posted by Blue_Eyez_ View Post
    when the fan on the radiator or the a/c compressor kicks on the idle starts to die and then, I guess to keep the car from cutting off, it rev's to about 1500rpm, then down to almost dead, back to 1300, so on until the fan or compressor shuts off.

    My brother said it sounds like a vacuum leak? idk crap about working on cars...just thought I would ask you guys before I have to break down and take it to the dealer.
    A vacuum leak is possible. What if any work have you done to your car recently? The 06 MY has been known for bad/faulty drive by wire systems??? Deffinetly check under the hood while the car is running with the a/c on to see if you hear a hissing/sucking sound. If you do then it is a vacuum leak.. If you do not then start rechecking all the work you have had done recently.
    Last edited by 06grayrex; 11-15-2006 at 02:20 AM.
    Hawk-Eye Alliance #666
    Stage 2

  4. #3
    Registered User Blue_Eyez_'s Avatar
    Join Date
    Mar 2006
    Location
    Birmingham, AL
    Posts
    197
    I havent done any work on the car lately, but I did have to take it to the dealer to have them fix a CEL. It was something about the air compressor that is in the uppipe or something They said that something had come loose and they just plugged it back in. CEL was gone. Now that I think about it, that was about the time I first noticed the rough idle problem.

    I am going to change the oil tommorow and I will take a look and see if I can hear/see a leak anywhere...if not I guess I will just take it back to the dealer. I just hate being without my car

    Thanks for the help bro.
    HAWK-EYE ALLIANCE #44
    2006 SGM WRX
    Cobb Stage 2
    APS 3" Catted TBE
    H-Tech Springs
    Eibach 10mm Spacers

  5. #4
    Registered User 06grayrex's Avatar
    Join Date
    Mar 2006
    Location
    STL
    Posts
    379
    Well I don't know if I helped, but I usually always check the last thing that I did or had someone do first when I have problems. If you had the air compressor worked on last by the dealer, that would deffinetly be the first thing I would check. If the CEL comes back on then use your AP to check the code to see if it's the same code then go from there. Take care.
    Hawk-Eye Alliance #666
    Stage 2

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •