Power steering not working right?...HELP!?
Results 1 to 15 of 15

This is a discussion on Power steering not working right?...HELP!? within the General Maintenance, Troubleshooting & Accidents. forums, part of the Tech & Modifying & General Repairs category; So for the past few days, my power steering hasn't been working right. Its not too bad, but I can ...

  1. #1
    Registered User
    Join Date
    Feb 2005
    Location
    Michigan
    Posts
    475

    Power steering not working right?...HELP!?

    So for the past few days, my power steering hasn't been working right. Its not too bad, but I can definitely feel it acting up. When i turn the wheel sometimes it will go off and go on in short little spurts...but its when i'm driving or just sitting there i can do it to if i can turn the wheel real quick one way and back the other way, i can sit there and do that as many times as i want, and the power steering almost acts like it won't catch up and its stop working. Not sure what to do. Checked my fluid levels and they're fine and plenty full. I just went stage 4 so I don't know if I should take it to the dealership or not. Please help...thanks!

  2. Remove Advertisements
    ClubWRX.net
    Advertisements
     

  3. #2
    Administrator Trainrex's Avatar
    Join Date
    May 2003
    Posts
    26,592
    I Support ClubWRX
    Is the belt squeeking?

    Have you done alot of donuts with the car?

  4. #3
    Registered User
    Join Date
    Apr 2006
    Location
    Sioux Falls, SD
    Posts
    921
    Have you changed the pullies?
    My water heater has a blow off valve.

  5. #4
    Registered User
    Join Date
    Feb 2005
    Location
    Michigan
    Posts
    475
    belt is not squeeking...and the only pulley i changed was the crank pulley and put a lightened one on...but now the stock has been back on for a solid 3 months. when i first start driving it, it really sounds like i can hear the pump or a buzzing noise working real hard...

  6. #5
    Registered User
    Join Date
    Feb 2005
    Location
    Michigan
    Posts
    475
    i did a few donutes...way back last winter..but not many at all..like 10 full rotations prolly...and that about 9 months ago?... can anyone guess what it might be? seems like it might be getting worse and worse each day...just ever so slightly.

  7. #6
    Administrator Trainrex's Avatar
    Join Date
    May 2003
    Posts
    26,592
    I Support ClubWRX
    Quote Originally Posted by LittleAP783
    i did a few donutes...way back last winter..but not many at all..like 10 full rotations prolly...and that about 9 months ago?... can anyone guess what it might be? seems like it might be getting worse and worse each day...just ever so slightly.
    Sounds like the pump to me. Donuts are really hard on the pump.

  8. #7
    Registered User adam3482p's Avatar
    Join Date
    Feb 2004
    Location
    Hickory, NC
    Posts
    2,553
    I played in the snow a few years back and it broke the power steering pump. Sounds like thats what happened.
    2009 Honda Accord Coupe EX-L Belize Blue Pearl

    2000 Yamaha R6
    10.123 At 131.9mph (Dyno Drags)
    111.1hp@wheel

    2002 Aspen White 5MT WRX - Sold

  9. #8
    Registered User
    Join Date
    Feb 2005
    Location
    Michigan
    Posts
    475
    how much is the power steering pump to replace?....where can i get one cheap?

  10. #9
    Registered User adam3482p's Avatar
    Join Date
    Feb 2004
    Location
    Hickory, NC
    Posts
    2,553
    hmmm, I got mine replaced under warrenty?
    2009 Honda Accord Coupe EX-L Belize Blue Pearl

    2000 Yamaha R6
    10.123 At 131.9mph (Dyno Drags)
    111.1hp@wheel

    2002 Aspen White 5MT WRX - Sold

  11. #10
    Registered User
    Join Date
    Feb 2005
    Location
    Michigan
    Posts
    475
    being stage 4 i wonder if they're gonna cover it though? even thought the p/s pump doesnt really have anything to do with bigger injectors and turbo and crap. but you know dealerships, they're gonna wanna hassle me....I found them for sale on-line for about $400 shipped. That's so frick'n darn much. What else could it be if its not the pump..fluid is fine. I thought something might have happened during the install beacuse it started doing it about 3 days after we did the stage 4 install.

  12. #11
    Registered User
    Join Date
    Oct 2005
    Location
    California
    Posts
    848
    I had the same thing that happened to me. For my case, I thought it was the steering pump, but when I brought it to the dealership to have it fixed, they found out the steering rack was bad. So they replaced it the whole thing under warranty and my car being an AP stage 2.

    I'm not suggesting that it could be it, but it's another possibility you should check. I suggest you bring it to the the dealership and have it figured out. I think the only bad thing that can happen is getting turned down for the job under warranty. If so, try bringing it to another dealership. Wish you luck!
    I might be back in the market for the new STI sedan!

  13. #12
    Moderator beastcivic's Avatar
    Join Date
    Mar 2002
    Location
    Charlotte, NC (USA)
    Posts
    1,832
    Mine did this same thing over the summer, with no belt squeak. However, now that it has gotten colder, I have a belt squeak. So you may have the belt slipping and just not know it.

    Mine will come on and off like yours at idle, but if I give it a little bit of gas and move the wheel it will no longer have inconsistent resistance in the wheel. And it only happens when initially started, after running for 30 seconds or so it won't happen again until the car gets cold again. Might be worth checking the belt before you go into more expensive diagnosis.
    -Jim

    '02 Platinum Silver WRX sedan w/roof rack...bone stock. Ok, now that's a lie.

    GO HOKIES!!!!!!!!!

  14. #13
    Registered User sigurd's Avatar
    Join Date
    Sep 2006
    Location
    nashville
    Posts
    218
    well donunts done correctly arent that bad on the pump at all.

    You just cant hold it all the way in one direction for any length of time. If your not making it dump the pressure it shouldnt really hurt it at all.

  15. #14
    Registered User adam3482p's Avatar
    Join Date
    Feb 2004
    Location
    Hickory, NC
    Posts
    2,553
    Quote Originally Posted by sigurd View Post
    well donunts done correctly arent that bad on the pump at all.

    You just cant hold it all the way in one direction for any length of time. If your not making it dump the pressure it shouldnt really hurt it at all.
    yup.

    P.S. I was a donut n00b when I broke mine.
    2009 Honda Accord Coupe EX-L Belize Blue Pearl

    2000 Yamaha R6
    10.123 At 131.9mph (Dyno Drags)
    111.1hp@wheel

    2002 Aspen White 5MT WRX - Sold

  16. #15
    Registered User motormike's Avatar
    Join Date
    Dec 2006
    Posts
    140
    has it been snowing near you? hehehe...drifting around lately?

    i had a friend who burnt his out doing donuts in a parking lot that was completely black-iced over was upsetting, but funny to watch him drive home with while trying to shift and turn

    if it keeps up or worsens, get it checked...they burn out when you keep it in one direction for too long, and im not talking about on a simple turn, more like sharp, fast, and for long lengths of time...just keep it mobile next time, if you were doing donuts or w/e u were doing
    **** off with your candy paint jobs and spoilers that are 8x too big , I say never be complete, I say stop being perfect, I say let... lets evolve, let the chips fall where they may.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •