threw a code, and i have no idea why
Page 1 of 2 12 LastLast
Results 1 to 15 of 23

This is a discussion on threw a code, and i have no idea why within the General Maintenance, Troubleshooting & Accidents. forums, part of the Tech & Modifying & General Repairs category; P0546 Exhaust gas temperature sensor circult high input..... anybody else had this problem?.. i'm pretty sure i'm just gonna reset ...

  1. #1
    Registered User
    Join Date
    Oct 2006
    Posts
    63

    threw a code, and i have no idea why

    P0546 Exhaust gas temperature sensor circult high input..... anybody else had this problem?.. i'm pretty sure i'm just gonna reset the ecm and simulate the sensor if there's a further issue.. time for a trip to radio shack.. but yeah.. what the hell is up w/that.. am i running lean or something?
    03 WRX - daily driver
    91 teg - needs a trans, the current one is soup.

  2. Remove Advertisements
    ClubWRX.net
    Advertisements
     

  3. #2
    Registered User AwdTurboWrx's Avatar
    Join Date
    Mar 2004
    Location
    Sun Valley,CA
    Posts
    5,793
    mods?
    The Ghosts of Zooph and Sarcasmo Will haunt CLUBWRX forever!!!

  4. #3
    Registered User
    Join Date
    Oct 2006
    Posts
    63
    cheap BOV that came with the car, but i'm sure that's not the issue
    03 WRX - daily driver
    91 teg - needs a trans, the current one is soup.

  5. #4
    Registered User rr1911's Avatar
    Join Date
    Nov 2005
    Location
    Central Florida
    Posts
    0
    Quote Originally Posted by function/form
    P0546 Exhaust gas temperature
    the gas coming out of your exhaust is to hot !

  6. #5
    Registered User rr1911's Avatar
    Join Date
    Nov 2005
    Location
    Central Florida
    Posts
    0
    Quote Originally Posted by Trainrex
    Either the egt sensor in your uppipe is faulty, or you have a catless uppipe.
    yea this might be why too !!!

  7. #6
    Registered User AwdTurboWrx's Avatar
    Join Date
    Mar 2004
    Location
    Sun Valley,CA
    Posts
    5,793
    Quote Originally Posted by Trainrex
    Either the egt sensor in your uppipe is faulty, or you have a catless uppipe.

    there you go. When i traded in my bugeye i just left the uppipe on because it was too much of a hassle to remove and go back to stock.
    The Ghosts of Zooph and Sarcasmo Will haunt CLUBWRX forever!!!

  8. #7
    Registered User D0WNxSH1FT's Avatar
    Join Date
    Oct 2004
    Location
    Westchester Cnty, NY
    Posts
    6,545
    +1 Its your EGT. Same thing happened to a friend of mine that bought a used 02. She wound up taking it to Subaru 4 times before they fixed it. (UP isnt exactly easy to get to, so they would never look at it to really fix the problem).
    2008 Satin White Pearl WRX Sedan w/ Navi
    2005 San Remo Red WRX Sedan w/ VF34 (traded)
    Pi Kappa Alpha | New England Flat 4

  9. #8
    Registered User
    Join Date
    Oct 2006
    Posts
    63
    i'm pretty sure there's a cat there... but it could just look that way?.. i dunno.. i'm gonna have to check it out. do the sensors go bad alot, or do ppl just go catless and it rapes the sensors into submission, ruining them?
    03 WRX - daily driver
    91 teg - needs a trans, the current one is soup.

  10. #9
    Registered User rr1911's Avatar
    Join Date
    Nov 2005
    Location
    Central Florida
    Posts
    0
    Quote Originally Posted by function/form
    i'm pretty sure there's a cat there... but it could just look that way?.. i dunno.. i'm gonna have to check it out. do the sensors go bad alot, or do ppl just go catless and it rapes the sensors into submission, ruining them?
    i heard that sensor breaks pretty easy when people change their up pipe... also might want to try some thermo wrap, thats might help

  11. #10
    Registered User
    Join Date
    Oct 2006
    Posts
    63
    yeah, somebody's definitely modified the car in the past... so i'll have to get a new sensor or something.. anybody know how much they run?
    03 WRX - daily driver
    91 teg - needs a trans, the current one is soup.

  12. #11
    Moderator YBNormal07's Avatar
    Join Date
    Jul 2003
    Location
    PA
    Posts
    6,245
    I Support ClubWRX
    If it is just the sensor, get the resistor mod fix from radio shack.

    If you have a cat installed, might want to have it looked at. If your UP cat is plugging (which would give you a high EGT temperature), the next step is melting and shredding and then by by turbo. After all, mainly, that is what the EGT is for on our boosted cars. Better to be safe then sorry.
    tEh PriUs=teH faSTah!@@!
    08 Audi S5 Black Diamond edition
    SOLD: 05 SWP Legacy GT Limited 5MT, 13.3ish@105 (stage 2) crappy stock clutch
    SOLD: 04 MPS/SW WRX Sti. 12.971 @ 103.97 (stock)
    278 AWHP/283 AWT, Catback exhaust
    306 AWHP/341 AWT, Stage 2
    (Scott) Moderator-STi, Drag Racing, Car Purchasing, and Tutorial Forums

  13. #12
    Registered User ktmrider's Avatar
    Join Date
    Sep 2006
    Location
    Albuquerque, NM
    Posts
    124
    Quote Originally Posted by YBNormal07
    If it is just the sensor, get the resistor mod fix from radio shack.

    If you have a cat installed, might want to have it looked at. If your UP cat is plugging (which would give you a high EGT temperature), the next step is melting and shredding and then by by turbo. After all, mainly, that is what the EGT is for on our boosted cars. Better to be safe then sorry.
    +1
    Find out if you have a catless UP. Most aftermarket UP delete the EGT and even come with the proper resistor ( 2.2K ohm, 1/2 watt ). The EGT pokes out from under the turbo and connects on the LH side by the boost sensor and O2 plug.
    If you don't have a catless UP then gut your stocker or replace. Turbo impellers and metal objects = replacement turbo.
    2005 Legacy GT - stock for now
    1991 Galant VR4 - Sold
    2002 WRX Wagon - Sold

  14. #13
    Registered User
    Join Date
    Oct 2006
    Posts
    63
    yeah, the resistor bit is probably the route i'll end up going..because i'm lazy and it costs less than a dollar. lol.. i could care less if my cat is burning/melting/decomposing.. as long as my computer doesn't know that, and i can pass emissions for OBDII, i'm a happy guy.
    03 WRX - daily driver
    91 teg - needs a trans, the current one is soup.

  15. #14
    He simply abides. SD_GR's Avatar
    Join Date
    Jul 2002
    Location
    CA, US
    Posts
    22,450
    I Support ClubWRX
    Quote Originally Posted by function/form
    i could care less if my cat is burning/melting/decomposing.. as long as my computer doesn't know that, and i can pass emissions for OBDII, i'm a happy guy.
    If pieces end up in the turbo, will your joy continue unhindered?
    WRX Info Links, Courtesy TheJ
    The world breaks everyone and afterward many are strong in the broken places. Ernest Hemingway
    I lied. I cheated. I bribed men to cover the crimes of other men. I am an accessory to murder. But the most damning thing of all... I think I can live with it. And if I had to do it all over again - I would. Benjamin Sisko
    DISCLAIMER: Opinions expressed are the author's alone and are inherently worthless.

  16. #15
    Registered User
    Join Date
    Oct 2006
    Posts
    63
    eh, its downstream from the turbo.. i don't see it being an issue, but i guess it could happen.. i dunno.... anyways, i need a new stock turbo, i have a cracked flange on it, so i could really care less if it dies.. the turbo is warrantied right now, part of my deal when i bought the car, it'll be alright.
    03 WRX - daily driver
    91 teg - needs a trans, the current one is soup.

Page 1 of 2 12 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •