power problem
Results 1 to 4 of 4

This is a discussion on power problem within the General Maintenance, Troubleshooting & Accidents. forums, part of the Tech & Modifying & General Repairs category; Ok today after droping off a friend i was puffing out into the street and car jearked really bad then ...

  1. #1
    Registered User Decon's Avatar
    Join Date
    Feb 2006
    Posts
    861

    power problem

    Ok today after droping off a friend i was puffing out into the street and car jearked really bad then keep going and my check engine light turned on. Then after driving a little bit noticed that mosty is 2nd when i hit 4k i lose all my power for about half a second and get it back. Doesent do this while just reving or bring power while in gear slowly. When I was giving at least 50% gas. Didnt do any more times in 1st and happens on a small scale in 3rd.
    And help would be greatfull, and yes im taking to dealer as soon as I can. O ya BTW its an 05. And also been raining going though water, so im hoping its not water.

  2. Remove Advertisements
    ClubWRX.net
    Advertisements
     

  3. #2
    Registered User WRXcelration's Avatar
    Join Date
    Apr 2004
    Location
    Allentown PA
    Posts
    2,797
    go to autozone or if you have an AP, pull the code and see what it is...then find out what the code is and we can help you from there...it may be due to the water...if you have a CAI which i pray you dont, your intake make suck in water or maybe something electrical could have gotten wet and needs to dry out....all you can do if pull the code and see what it is and go from there
    05 STI

    Speed Comes At A Price...How Fast Can You Afford To Go?

  4. #3
    Registered User Decon's Avatar
    Join Date
    Feb 2006
    Posts
    861
    lol its ended up being something really stupid lol. My Maf sencor was unplugged a little bit lol.

  5. #4
    Registered User orvtech's Avatar
    Join Date
    Nov 2005
    Location
    Miami
    Posts
    1,077
    Quote Originally Posted by Decon
    lol its ended up being something really stupid lol. My Maf sencor was unplugged a little bit lol.
    this remind me ... chake it out and see if it is clean, if you are using oil based air filter it could be durty

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •