Bad Walbro Fuel pumps??
+ Reply to Thread
Results 1 to 3 of 3

This is a discussion on Bad Walbro Fuel pumps?? within the General Maintenance, Troubleshooting & Accidents. forums, part of the Tech & Modifying & General Repairs category; Just a quick question about Walbro 255lph fuel pumps. Anyone else had an experience like mine where they had a ...

  1. #1
    Registered User Speedmonkey's Avatar
    Join Date
    Feb 2006
    Posts
    207

    Bad Walbro Fuel pumps??

    Just a quick question about Walbro 255lph fuel pumps. Anyone else had an experience like mine where they had a new fuel pump go bad after just a few miles? I had one go bad on me after less than 2k miles that stranded me in the middle of nowhere. 250 dollar tow and 1 new fuel pump later my car is running strong again. I plan on calling Walbro and seeing if they will reimburse me for my trouble. I know it's a long shot but hopefully they have some sort of warranty for issues like this.
    '04 STI WRB,FP Green'ed and Protuned. (Gone )

    366.7whp/374.1wtq @20psi on 92 octane

  2. Remove Advertisements
    ClubWRX.net
    Advertisements
     

  3. #2
    Registered User clbourq's Avatar
    Join Date
    Nov 2005
    Location
    Hilton Head Island, SC
    Posts
    69

    walbro

    I also have a walbro fuel pump. Before it went bad, did you ever have a smell of gas in your car or did it just all of a sudden punk out on ya? Good luck to ya on getting somethin out of all this.

  4. #3
    Registered User Speedmonkey's Avatar
    Join Date
    Feb 2006
    Posts
    207
    Nope, I was passing some trucks on a slight hill and right after I got around them my car just died. After that it would start but wouldn't rev past 2k without dying, then it wouldn't start at all. lol The reason I fiugred out it was the fuel pump was that I couldn't hear the whine right as I turned the key on so I checked to see if it was getting power and it was. Replaced the pump and it fired right up and has been running fine ever since.
    '04 STI WRB,FP Green'ed and Protuned. (Gone )

    366.7whp/374.1wtq @20psi on 92 octane

+ Reply to Thread

Quick Reply Quick Reply

Register Now

Please enter the name by which you would like to log-in and be known on this site.
If you do not want to register, fill this field only and the name will be used as user name for your post.

Please enter a password for your user account. Note that passwords are case-sensitive.

Please enter a valid email address for yourself. We strongly suggest that you stay away from using aol, yahoo, msn, and hotmail accounts. Sometimes the mail server blocks the emails from our server. As a result you will not receive any notifications including the confirmation email.

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.


Posting Permissions

  • You may post new threads
  • You may post replies
  • You may not post attachments
  • You may not edit your posts
  •