How often does your AC compressor disengage?
Results 1 to 15 of 15

This is a discussion on How often does your AC compressor disengage? within the General Maintenance, Troubleshooting & Accidents. forums, part of the Tech & Modifying & General Repairs category; Having problems with my AC compressor not staying engaged. The clutch will disengage after the compressor has been running for ...

  1. #1
    zum
    zum is offline
    Registered User zum's Avatar
    Join Date
    Aug 2004
    Location
    Billings, MT
    Posts
    23

    How often does your AC compressor disengage?

    Having problems with my AC compressor not staying engaged. The clutch will disengage after the compressor has been running for 8-10 seconds. Then after about 5 seconds, it will kick back on. That's really annoying. The air will go from cold-warm-cold...

    Took it in for service yesterday. When I got it back, it acted the same exact way. But now I have greasy hand prints on my hood.

    Anyone elses behave this way? Did some searching but didn't find anything relevant.
    04 Aspen White WRX Sedan

  2. Remove Advertisements
    ClubWRX.net
    Advertisements
     

  3. #2
    Administrator Trainrex's Avatar
    Join Date
    May 2003
    Posts
    26,590
    I Support ClubWRX
    Quote Originally Posted by zum
    Having problems with my AC compressor not staying engaged. The clutch will disengage after the compressor has been running for 8-10 seconds. Then after about 5 seconds, it will kick back on. That's really annoying. The air will go from cold-warm-cold...

    Took it in for service yesterday. When I got it back, it acted the same exact way. But now I have greasy hand prints on my hood.

    Anyone elses behave this way? Did some searching but didn't find anything relevant.
    Is this at idle, or when you are driving?

  4. #3
    Registered User blarg's Avatar
    Join Date
    Mar 2002
    Location
    Calmer than you are
    Posts
    10,366
    it tells me it doesn't want to get married, gives me back the ring, and runs off crying.
    ScoobyDMC #009 - making dirty jokes since before you were making dirty diapers.
    Quote Originally Posted by Blarg
    go f*** yourself

  5. #4
    Registered User flyingpertyhigh's Avatar
    Join Date
    Mar 2006
    Location
    Brookline MA
    Posts
    164
    mine does exactly that. pisses me off. figured its just a shi*** design

  6. #5
    zum
    zum is offline
    Registered User zum's Avatar
    Join Date
    Aug 2004
    Location
    Billings, MT
    Posts
    23
    Quote Originally Posted by Trainrex
    Is this at idle, or when you are driving?
    At idle it'll stay engaged. This is when driving. It acted the same when parked but holding the revs at ~2500 rpms.

    Quote Originally Posted by flyingpertyhigh
    mine does exactly that. pisses me off. figured its just a shi*** design
    I can't imagine it's good for the compressor clutch.
    04 Aspen White WRX Sedan

  7. #6
    Moderating on the run! Big Sky WRX's Avatar
    Join Date
    Jul 2001
    Location
    Plains of Eastern Montana
    Posts
    12,344
    I Support ClubWRX
    Rick

    I get a good idle surge (750ish rpm->120ish rpm->750ish and so on) when the AC or defrost is on- pretty normal. What your describing isn't normal or if it is I haven't experienced it.

    Visit w/ Craig Olivia (service mgr) and have him take a drive w/ you- something is up.

    Mike
    "Simplify and add lightness." - Colin Chapman

  8. #7
    Registered User
    Join Date
    Jul 2004
    Location
    elk grove ca
    Posts
    925
    i get a pretty good surge while im driving, i just had a new compressor put in, and @3k rpm, my car will stumble for a split sec.. then about 15-20 secs later it will do the same.. its extremely annoying when highway driving anywhere..details behind getting a new compressor are: took my car in for loud abnoxious tapping sound coming from motor area ( i assumed it was valve tap).. timing belt tensioner gave causing tapping, replaced under warranty, while i was there i told them my AC blew hot air.. found old unit was completely non functional, was replaced under warranty.. now i get hesitation while driving with the ac on, and i still have a noticable tap coming from the motor...
    14.160@96.011
    90 degree weather
    airhog, removed silencer, and removed stock catback exhaust (stock DPs in place) and craptacular california 91 octane piss water

  9. #8
    Registered User 03wrxwgn's Avatar
    Join Date
    Oct 2005
    Location
    C.C., Texas
    Posts
    156
    Not stealing the thread but I hardly use my A/C and now that I turn it on...it Squeals like if I was murdering a Pig!!!!! For about 1min then it goes away... Its pretty embarassing!!! Is my A/C screwed???? Cold air comes out and it works perfectly except for the loud shreeeeeekkkk!!!!

  10. #9
    Registered User geefunk's Avatar
    Join Date
    Feb 2006
    Location
    Fargo, ND
    Posts
    626
    mine does the same thing. However, it stays cold the whole time.

  11. #10
    Registered User
    Join Date
    Mar 2006
    Posts
    99
    Do you guys also hear a hissing noise when it happens?
    Im guessing the sound of the compressor is engaging.

  12. #11
    Registered User Darrell's Avatar
    Join Date
    Sep 2004
    Location
    Indy, IN
    Posts
    715
    Quote Originally Posted by 03wrxwgn
    Not stealing the thread but I hardly use my A/C and now that I turn it on...it Squeals like if I was murdering a Pig!!!!! For about 1min then it goes away... Its pretty embarassing!!! Is my A/C screwed???? Cold air comes out and it works perfectly except for the loud shreeeeeekkkk!!!!
    Check the tension of the drive belt and adjust as necessary.
    Mine: '05 PSM WRX 5MT Sport Wagon, Cobb AP
    Wife's: '05 SRR 2.5RS 5MT Sport Wagon

    The Knack. It's a rare condition characterized by an extreme intuition about all things mechanical and electrical ... and utter social ineptitude.

  13. #12
    Registered User
    Join Date
    Nov 2003
    Location
    Los angeles
    Posts
    120
    My AC squeals like a pig as well, seems to be getting worse. If I have not run it for a period of time it goes crazy, then goes away...However as the compressor cycles, turns on and off every few minutes, when it cycles on it does one quick squeal...annoying to say the least.

  14. #13
    Registered User dcpatters's Avatar
    Join Date
    Sep 2004
    Location
    Irvine, CA
    Posts
    1,174
    Quote Originally Posted by zum
    Having problems with my AC compressor not staying engaged. The clutch will disengage after the compressor has been running for 8-10 seconds. Then after about 5 seconds, it will kick back on. That's really annoying. The air will go from cold-warm-cold...
    Sounds like a low pressure switch; perhaps from low freon. When this happens, the AC compressor will engage and disengage sporadically as its desinged to do. Have the freon level checked.
    2008 Evo X GSR. Custom tuned, Works panel filter, Intercooler pipe upgrade, TBE.

  15. #14
    Registered User blarg's Avatar
    Join Date
    Mar 2002
    Location
    Calmer than you are
    Posts
    10,366
    Quote Originally Posted by Balthus
    My AC squeals like a pig as well, seems to be getting worse. If I have not run it for a period of time it goes crazy, then goes away...However as the compressor cycles, turns on and off every few minutes, when it cycles on it does one quick squeal...annoying to say the least.
    that could be a loose pulley. I had this problem too...just had them tighten it and the squeal went away. I also had a different squeal (more like bearing squeal) when the compressor was going out.
    ScoobyDMC #009 - making dirty jokes since before you were making dirty diapers.
    Quote Originally Posted by Blarg
    go f*** yourself

  16. #15
    Registered User
    Join Date
    Jul 2006
    Location
    Utah
    Posts
    3
    Quote Originally Posted by zum
    Having problems with my AC compressor not staying engaged. The clutch will disengage after the compressor has been running for 8-10 seconds. Then after about 5 seconds, it will kick back on. That's really annoying. The air will go from cold-warm-cold...

    Took it in for service yesterday. When I got it back, it acted the same exact way. But now I have greasy hand prints on my hood.

    Anyone elses behave this way? Did some searching but didn't find anything relevant.
    I have this exact same problem. It disengages every 5 seconds or so and makes the whole car bog plus a loud knock from under the hood. I'm starting to think it's low freon since I don't get ice cold air anyway.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •