Random engine lights
Page 1 of 2 12 LastLast
Results 1 to 15 of 18

This is a discussion on Random engine lights within the General Maintenance, Troubleshooting & Accidents. forums, part of the Tech & Modifying & General Repairs category; I bought my 2002 WRX 4EAT wagon last year. I added a BOV and since then the AT OIL TEMP ...

  1. #1
    Registered User
    Join Date
    Jul 2006
    Location
    Upstate NY
    Posts
    51

    Random engine lights

    I bought my 2002 WRX 4EAT wagon last year. I added a BOV and since then the AT OIL TEMP light comes on when I punch it in the rain...went to dealer, no big deal they said. It always clears itself out when I restart. Anyway here is my question...
    I was driving the other day with the A/C on. I parked the car, and when I hit the brake the ABS light flashed on as the car almost bogged out. I know the A/C drains the power, so I disregarded it. On the rest of my 260 mile trip, when I was cruising on the highway, if I hit the brakes the ABS light and AT OIL TEMP light would flash on and the speedometer would drop. The car was still running fine, so maybe an electrical problem???
    Any info. is appreciated, I am driving from NY to CA next week and need to know if something may need replacement...
    Thanks,

  2. Remove Advertisements
    ClubWRX.net
    Advertisements
     

  3. #2
    Registered User bkotzman00's Avatar
    Join Date
    Apr 2006
    Location
    York, PA
    Posts
    1,865
    take off the BOV, it will solve all of your problems just do a search and see why not to add a BOV
    04 WRX Java Black
    Mustang Dyno 218 awhp 216 awtq
    1978 Honda CB400Tll
    yea you know its modified
    1974 Honda CB750 Bobber
    still in the works

  4. #3
    Registered User
    Join Date
    Jul 2004
    Location
    elk grove ca
    Posts
    925
    completely disregarding that BOVs suck on wrxs.. why on gods green earth would you put a BOV on a 4EAT anyway?
    14.160@96.011
    90 degree weather
    airhog, removed silencer, and removed stock catback exhaust (stock DPs in place) and craptacular california 91 octane piss water

  5. #4
    Administrator Trainrex's Avatar
    Join Date
    May 2003
    Posts
    26,591
    I Support ClubWRX
    Quote Originally Posted by bkotzman00
    take off the BOV, it will solve all of your problems just do a search and see why not to add a BOV
    I don't care for BOV's, but how is removing it going to solve the problems?

  6. #5
    Registered User
    Join Date
    Jul 2004
    Location
    elk grove ca
    Posts
    925
    Quote Originally Posted by Trainrex
    I don't care for BOV's, but how is removing it going to solve the problems?
    cuz BOVs cause simultaneous suckage of everything on our cars
    Last edited by blackrex02; 07-20-2006 at 07:34 PM.
    14.160@96.011
    90 degree weather
    airhog, removed silencer, and removed stock catback exhaust (stock DPs in place) and craptacular california 91 octane piss water

  7. #6
    Registered User armysti's Avatar
    Join Date
    Apr 2006
    Location
    tucson AZ
    Posts
    615
    the bov wouldnt have anything to do with the abs light coming on. it sounds more electric to me.

  8. #7
    Registered User armysti's Avatar
    Join Date
    Apr 2006
    Location
    tucson AZ
    Posts
    615
    i would take it into subaru and get it looked at before u head home. just to be on the safe side.

  9. #8
    Registered User bkotzman00's Avatar
    Join Date
    Apr 2006
    Location
    York, PA
    Posts
    1,865
    my bad, took to quick of a look at the tread and saw that a BOV was installed and assumed that all of the problems were related to that, my bad I was wrong. but to me it sounds similar to when my alternator went bad the voltage would drop and when that happened the speedo would blip and the various lights on the dash would come on. not sure but does the brake system need electricity to power the master cylinder so when pressing the brakes causing a voltage drop?
    04 WRX Java Black
    Mustang Dyno 218 awhp 216 awtq
    1978 Honda CB400Tll
    yea you know its modified
    1974 Honda CB750 Bobber
    still in the works

  10. #9
    Registered User
    Join Date
    Jul 2004
    Location
    elk grove ca
    Posts
    925
    i still think its the BOV
    14.160@96.011
    90 degree weather
    airhog, removed silencer, and removed stock catback exhaust (stock DPs in place) and craptacular california 91 octane piss water

  11. #10
    Registered User bkotzman00's Avatar
    Join Date
    Apr 2006
    Location
    York, PA
    Posts
    1,865
    yea the BOV has to go. but go to an Auto Zone and have your alternator checked - its free and couldn't hurt to check to see if that is causing the problems.
    04 WRX Java Black
    Mustang Dyno 218 awhp 216 awtq
    1978 Honda CB400Tll
    yea you know its modified
    1974 Honda CB750 Bobber
    still in the works

  12. #11
    Moderator YBNormal07's Avatar
    Join Date
    Jul 2003
    Location
    PA
    Posts
    6,245
    I Support ClubWRX
    Did you verify all vacuum lines are plugged/connected when you swapped out the BOV? The conditions under which these issues are occuring sound suspiciously like low vacuum conditions to me. Thus, a vacuum leak could be the culprit.
    tEh PriUs=teH faSTah!@@!
    08 Audi S5 Black Diamond edition
    SOLD: 05 SWP Legacy GT Limited 5MT, 13.3ish@105 (stage 2) crappy stock clutch
    SOLD: 04 MPS/SW WRX Sti. 12.971 @ 103.97 (stock)
    278 AWHP/283 AWT, Catback exhaust
    306 AWHP/341 AWT, Stage 2
    (Scott) Moderator-STi, Drag Racing, Car Purchasing, and Tutorial Forums

  13. #12
    Registered User
    Join Date
    Jul 2006
    Location
    Upstate NY
    Posts
    51
    I removed the BOV today. It was installed correctly, very easy install.

    I put it on because yes it is a 4eat, but still makes the sound as soon as you let off the gas. Making the noise was the purpose. It is more or less my wifes' car and she likes the noise.

    It may be the alternator, it would make sense, but it hasn't really gotten much worse(besides the lights) and it has been doing it since Oct 06.

    Hmmmmmm...

  14. #13
    Registered User
    Join Date
    Jul 2006
    Location
    Upstate NY
    Posts
    51
    I was searching other forums...does it sound like the alternator ground maybe...
    Thanks for the info.

  15. #14
    Registered User
    Join Date
    Jul 2006
    Location
    Upstate NY
    Posts
    51
    Wanted to let you know I removed the BOV and cleaned the terminals...everything is great now...thanks for the help!

  16. #15
    Moderator YBNormal07's Avatar
    Join Date
    Jul 2003
    Location
    PA
    Posts
    6,245
    I Support ClubWRX
    Just cleaning the terminals eh? wow..whodathunkit
    tEh PriUs=teH faSTah!@@!
    08 Audi S5 Black Diamond edition
    SOLD: 05 SWP Legacy GT Limited 5MT, 13.3ish@105 (stage 2) crappy stock clutch
    SOLD: 04 MPS/SW WRX Sti. 12.971 @ 103.97 (stock)
    278 AWHP/283 AWT, Catback exhaust
    306 AWHP/341 AWT, Stage 2
    (Scott) Moderator-STi, Drag Racing, Car Purchasing, and Tutorial Forums

Page 1 of 2 12 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •