Another Smoke out of my hood...just a little bit
Results 1 to 3 of 3

This is a discussion on Another Smoke out of my hood...just a little bit within the General Maintenance, Troubleshooting & Accidents. forums, part of the Tech & Modifying & General Repairs category; Ok guys i drove up to East Lansing to visit my girfriend at MSU, its about an 80 mile drive. ...

  1. #1
    Registered User
    Join Date
    Jan 2006
    Location
    Clarkston, MI
    Posts
    54

    Another Smoke out of my hood...just a little bit

    Ok guys i drove up to East Lansing to visit my girfriend at MSU, its about an 80 mile drive. so i get there and then we take my car to the parking garage. well once i park my car at a stop, after about 2 mintues smoke started coming out of my hoodscoop, it wasnt a lot but enough for me to notice. so i turned it off and it slowly went away. after about 2 mintues i turned it on again...nothing. no smoke at all. i had my upipe and downpipe installed ohhh like 4 weeks ago when i first bought it a coolant line ( dont know where it went but it was above the turbo going across it) was leaking because it wasnt clamped on right, so i checked it and no leaking whatsoever oil level is fine too, it was the first time that has happened to me, the temp gauge never moved. i guess im hoping maybe it was just too hott????? i dunno please help me guys...i hope its nothing, especially nothing big i dont wnt to bring out the credit card.

  2. Remove Advertisements
    ClubWRX.net
    Advertisements
     

  3. #2
    Registered User
    Join Date
    Feb 2005
    Posts
    38
    hey mine does the same thing sometimes and i have the same mods. the only thing that i have different is the heat wrap. if you have heat wrap, then what is mostlikey the cause of the smoke. its the up pipe burning the heat wrap because it gets 1800 degrees.

  4. #3
    Registered User
    Join Date
    Apr 2006
    Posts
    21
    was it smoke or steam? does it smell like anything's burning? If it's just a bit of steam, it could have been a bit of moisture that hit the turbo heat shielding. From your description of it "smoking" then you waiting a while and driving it again and observing no "smoke" i'm lead to believe that it was indeed some bit of water or other moisture that hit your turbo or something else hot under the hood. (i used to see some steam rising off the hood of my old car in the rain or fog caused by moisture splattering onto the header). regardless, next time it happens, pop the hood and find out exactly where it's coming from. otherwise, it doesn't sound like a big deal.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •