check engine light...
Results 1 to 10 of 10

This is a discussion on check engine light... within the General Maintenance, Troubleshooting & Accidents. forums, part of the Tech & Modifying & General Repairs category; Hey all, i couldnt find a place to put this so since im kinda new, i decided to put it ...

  1. #1
    Registered User The An$wer's Avatar
    Join Date
    Jan 2006
    Location
    Modesto, CA
    Posts
    257

    check engine light...

    Hey all, i couldnt find a place to put this so since im kinda new, i decided to put it here... well it starts like this, the past few weeks here in modesto, CA we've had the nuttyest weather, sun rain sun rain hail rain hail sun bla bla... and thats in one day sometimes... Anyways, today it poored HARD. Floods and stuff, i was driving my ReX and the street i was on was getting flooded quick, I had no choice but to drive through most the puddles so i had some fun going through them like i nomally do. At some point while i was going through one of them, my car like died for a second or something, then the check engine light came on and the cruise started to flash... i drove for a few mins after this as i had no choice. I punched it in 2nd to see if anything was wrong, and the car hesitated real bad so i let off quick. i drove around the rest of the day barly giving it gas, then after sometime the check light went away as did the cruise flashing. Now the car seems fine... anyone have any clue wtf happend? I did the snorcal mod a while back before the weather went crazy... im going to put it back in tomorow morning, i think water might of been sucked in or something... anyone have any similar problems to this? The check engine light and cruise flashing happens to my friends STi a lot when he is over boosting, but im stock so it had to be something else.

  2. Remove Advertisements
    ClubWRX.net
    Advertisements
     

  3. #2
    Registered User Timberwolf0924's Avatar
    Join Date
    Apr 2006
    Location
    Georgia
    Posts
    102

    Lightbulb

    I had a problem very similar to this.

    The first thing I did was let it sit for about 4 hrs, and the light went away. If that didn't work and it still feels like it's like it's lagging then check the clutch. Mine was lagging and I changed the cluch so that went away, but the check engine light and cruise control kept going when I hit about 100mph, and it would sputter.

    I just changed the spark plugs and everything works fine now, you should try that, it may work.
    "When you have eliminated the impossible, whatever remains, however improbable, must be the truth." -Sir Arthur Conan Doyle-
    "When it hurts to much to look back, and you're to afraid to look ahead. Just look beside you and you'll find me there."
    -Unknown-

  4. #3
    Registered User The An$wer's Avatar
    Join Date
    Jan 2006
    Location
    Modesto, CA
    Posts
    257
    Quote Originally Posted by Timberwolf0924
    I had a problem very similar to this.

    The first thing I did was let it sit for about 4 hrs, and the light went away. If that didn't work and it still feels like it's like it's lagging then check the clutch. Mine was lagging and I changed the cluch so that went away, but the check engine light and cruise control kept going when I hit about 100mph, and it would sputter.

    I just changed the spark plugs and everything works fine now, you should try that, it may work.
    It seems fine now, i dont think i have to change my plugs as it only has 4000 miles on it...but il drive it kinda harder today and see if it acts up. Thanks for the advice..

  5. #4
    Registered User
    Join Date
    Mar 2006
    Posts
    99
    I had my CEL light on and cruise flash the day after I brought home my WRX. Ended up being the gas cap wasnt on tight enough. When I got it the dealer put a full tank in and aparently didnt get the cap back on right.

    What year is your rex?

  6. #5
    Registered User
    Join Date
    Apr 2004
    Location
    Salem, OR
    Posts
    10
    If this happened because of the puddle jumping, you may want to pull your air filter element and see if it is water logged. I've seen wet clutches slip, but not necessarily affect how the engine runs.

    Start with the simple stuff and keep us posted.

    Sy

  7. #6
    Registered User The An$wer's Avatar
    Join Date
    Jan 2006
    Location
    Modesto, CA
    Posts
    257
    Yeah i put the snorcal back in and it was kinda watery in taht area. So im guessing water got into the fender and in the intake... anyways its running fine now. future advice, dont do the snorcal mod, my car drives smoother with it in now as well...

  8. #7
    Registered User
    Join Date
    Mar 2008
    Posts
    1

    engine light

    i recently bought an 05 wrx i have put a greddys two stage boost controller on it and thats it, . but just a few hours ago i raced a friend of mine....any way when i shifted into third all of the sudden the car jerked pretty hard and then the engine light came on so i pulled over opened the hood, but everything was fine i let it rest for a bit then drove home. everything seemed fine while driving nothing seemed wrong at all. does any one know what happened? or has anyone had this problem?

  9. #8
    Registered User
    Join Date
    Apr 2010
    Location
    middleboro mass
    Posts
    9
    hey yesterday i changed my oil in my sti and the check engine light was on and the cruise contral light was flashing. neither were on before i changed my oil does anyone know why they are on.

  10. #9
    Registered User Timberwolf0924's Avatar
    Join Date
    Apr 2006
    Location
    Georgia
    Posts
    102
    What did was get my spark plugs changed and it went away. I don't know if that is what is was, but it cut them off for me. I changed them myself.
    "When you have eliminated the impossible, whatever remains, however improbable, must be the truth." -Sir Arthur Conan Doyle-
    "When it hurts to much to look back, and you're to afraid to look ahead. Just look beside you and you'll find me there."
    -Unknown-

  11. #10
    Registered User Timberwolf0924's Avatar
    Join Date
    Apr 2006
    Location
    Georgia
    Posts
    102
    Quote Originally Posted by tj_cwn View Post
    i recently bought an 05 wrx i have put a greddys two stage boost controller on it and thats it, . but just a few hours ago i raced a friend of mine....any way when i shifted into third all of the sudden the car jerked pretty hard and then the engine light came on so i pulled over opened the hood, but everything was fine i let it rest for a bit then drove home. everything seemed fine while driving nothing seemed wrong at all. does any one know what happened? or has anyone had this problem?
    My car does this as well. someone told me it was a blown head gasket, but only when I race so IDK. but let it cool down for a day or so and it'll get better. Though you may want to get it looked at.

    Quote Originally Posted by dc363 View Post
    hey yesterday i changed my oil in my sti and the check engine light was on and the cruise contral light was flashing. neither were on before i changed my oil does anyone know why they are on.
    See previous post.
    "When you have eliminated the impossible, whatever remains, however improbable, must be the truth." -Sir Arthur Conan Doyle-
    "When it hurts to much to look back, and you're to afraid to look ahead. Just look beside you and you'll find me there."
    -Unknown-

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •