boost problems
Results 1 to 2 of 2

This is a discussion on boost problems within the General Maintenance, Troubleshooting & Accidents. forums, part of the Tech & Modifying & General Repairs category; i looked doesnt seem right ... 1-2 gear is 10 - 9.5 psi 3-5 gear is 11-11.5psi the 1 and ...

  1. #1
    Registered User speeddr2000's Avatar
    Join Date
    Mar 2005
    Location
    jacksonville
    Posts
    284

    boost problems

    i looked doesnt seem right ... 1-2 gear is 10 - 9.5 psi 3-5 gear is 11-11.5psi the 1 and 2 gear is high and the 3 thru 5 is low. what could it be ? im using a brand new omori boost guage and my blitz dual tt both have the same reading. i got a new factory turbo put on about 4 months ago cause of boosting problems i hit 13.5 on the way back from miami and once coming for key west i cant ever hit 13.5 but only twice. u can feel the differance. my cel is on for a high temp in the cat. think i should gut the up pipe?

  2. Remove Advertisements
    ClubWRX.net
    Advertisements
     

  3. #2
    Moderator
    Join Date
    Jul 2003
    Location
    Maryland
    Posts
    11,098
    I Support ClubWRX
    Seems like you may have a WG issue. Do you have any mods at all to the car. What year is the car? If the turbo swap was done in warranty I'd take it back to the dealer and explain your issue.
    0-60 faster then your first sexual experience.
    "You've come far, and though you're far from the end
    You don't mind where you are, cause you know where you've been"

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •