2011 Intercooler boot clamp size
+ Reply to Thread
Results 1 to 8 of 8

This is a discussion on 2011 Intercooler boot clamp size within the General Maintenance, Troubleshooting & Accidents. forums, part of the Tech & Modifying & General Repairs category; I think I've narrowed down my boost leak to my intercooler boot. I was wondering what size t-bolt clamp they ...

  1. #1
    Registered User XJman's Avatar
    Join Date
    Feb 2015
    Location
    At work
    Posts
    3,832

    2011 Intercooler boot clamp size

    I think I've narrowed down my boost leak to my intercooler boot. I was wondering what size t-bolt clamp they take. I found one source that said 2.75 but I can only find 2.5 and 3. Can anyone who has replaced these to fix a leak there comment on what size clamp they used.

  2. Remove Advertisements
    ClubWRX.net
    Advertisements
     

  3. #2
    Registered User
    Join Date
    Mar 2016
    Posts
    18
    https://www.amazon.com/Mishimoto-MMC.../dp/B004MEGXLU

    I think summit racing also has some in stock as well

  4. #3
    Registered User XJman's Avatar
    Join Date
    Feb 2015
    Location
    At work
    Posts
    3,832
    So it is a 2.75. man that sucks I'd prefer to find them local.

    Sent from my Nexus 6 using Tapatalk

  5. #4
    Registered User
    Join Date
    Mar 2016
    Posts
    18
    I tried finding them locally but couldn't. I ended up just taking off the boots from both ends and reusing the worm clamps.

  6. #5
    Registered User XJman's Avatar
    Join Date
    Feb 2015
    Location
    At work
    Posts
    3,832
    Will they cinch down tight enough?

    Sent from my Nexus 6 using Tapatalk

  7. #6
    Registered User
    Join Date
    Mar 2016
    Posts
    18
    Sure will. The leak is just due to those stupid grommets subaru decided to use. Take a mental picture as to how the hose was before you remove it. I spent more time trying to get the right angle to put the hose on than I did removing the damn thing

  8. #7
    Registered User XJman's Avatar
    Join Date
    Feb 2015
    Location
    At work
    Posts
    3,832
    I figure I'll update this saga. So here is the deal. Everything was coming off nice and easy. I used a 12mm bit for my screw driver for all the bolts, all was good, all was well. Then the back bolt on my turbo said snap. I know I've got some ham hands but I have a feeling that someone has been here before because this boy came off with the twist of a wrist. I'm also assuming this is part of my boost leak issue as when the other bolt came loose the top mount had a slight wiggle to it.

    Oh well.


    Sent from my Nexus 6 using Tapatalk

  9. #8
    Registered User XJman's Avatar
    Join Date
    Feb 2015
    Location
    At work
    Posts
    3,832
    Got up today and drilled out the old bolt and did some thread repair. It isn't perfect by any means but it is beyond good enough for its purpose.

    Sent from my Nexus 6 using Tapatalk

+ Reply to Thread

Quick Reply Quick Reply

Register Now

Please enter the name by which you would like to log-in and be known on this site.

Please enter a password for your user account. Note that passwords are case-sensitive.

Please enter a valid email address for yourself. We strongly suggest that you stay away from using aol, yahoo, msn, and hotmail accounts. Sometimes the mail server blocks the emails from our server. As a result you will not receive any notifications including the confirmation email.

Please select your insurance company (Optional)

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.


Posting Permissions

  • You may post new threads
  • You may post replies
  • You may not post attachments
  • You may not edit your posts
  •