2012 WRX Stock Turbo Lag
+ Reply to Thread
Results 1 to 8 of 8

This is a discussion on 2012 WRX Stock Turbo Lag within the General Maintenance, Troubleshooting & Accidents. forums, part of the Tech & Modifying & General Repairs category; Hey! Is it normal that a bone stock 2012 WRX doesn't hit boost until 4k RPM?...

  1. #1
    Registered User
    Join Date
    Jun 2016
    Location
    Denver, CO
    Posts
    3

    2012 WRX Stock Turbo Lag

    Hey! Is it normal that a bone stock 2012 WRX doesn't hit boost until 4k RPM?

  2. Remove Advertisements
    ClubWRX.net
    Advertisements
     

  3. #2
    OMG WTF MainFrame's Avatar
    Join Date
    Sep 2002
    Location
    Texas, United States
    Posts
    9,968
    I Support ClubWRX I Support ClubWRX
    No

  4. #3
    Registered User kpeters's Avatar
    Join Date
    Feb 2012
    Location
    Chicago, IL
    Posts
    49
    What are you asking exactly? Is it not spooling until 4k or not hitting target boost until 4k? and how are you measuring it (AP, boost gauge)?

  5. #4
    Registered User
    Join Date
    Jun 2016
    Location
    Denver, CO
    Posts
    3
    Im hearing the turbo spool at about 3500 rpm. I feel full boost at 4k. I have neither an AP or boost gauge. Im simply going off of feel and sound. Thanks for helping out!

  6. #5
    Registered User kpeters's Avatar
    Join Date
    Feb 2012
    Location
    Chicago, IL
    Posts
    49
    It's kind of hard to troubleshoot if you don't have a method of measurement.... you could just do a boost leak test to make sure you aren't losing anything but beyond that, you need a way to know what your boost pressure is doing during spool.

    Food for thought.....In chicago, i(also bone stock) don't hit target boost (14-15 PSI indicated on BG) until roughly 3500k so maybe the altitude in denver might account for the extra 500? Not sure... someone else might want to chime in on that idea.

  7. #6
    Registered User
    Join Date
    Jun 2016
    Location
    Denver, CO
    Posts
    3
    Thanks! Ill look into an AP for it.

  8. #7
    Water.....sometimes waves rqjoe's Avatar
    Join Date
    Feb 2015
    Location
    Ohio
    Posts
    726
    I Support ClubWRX
    Quote Originally Posted by MainFrame View Post
    No
    LOL. You beat me to it.

  9. #8
    zax
    zax is offline
    Medicum Physicum zax's Avatar
    Join Date
    Nov 2008
    Location
    Neverland Ranch, Maryland
    Posts
    16,545
    I Support ClubWRX I Support ClubWRX
    Quote Originally Posted by snowwhitesubie View Post
    Thanks! Ill look into an AP for it.
    If you have a mechanical issue, an AP would not be a wise purchase.

    Sent from my SAMSUNG-SM-G890A using Tapatalk
    2015 CWP WRX STi ... But how did I get roped back into an EJ motor?!
    Zax's utterly stock 2015 STi - Seeking B-Stock supremacy
    Zax's Shaggin' Wagon (SOLD)

    Zach | Moderator | Builds, Electronics/Car Audio, Engine Modifications, Mid-Atlantic States, Suspension & Wheels, Tech & Modifying & General Repairs |
    Rollin' with the Bugeye Mafia #302
    Facebook me here

    Your Mid-A local board: http://www.clubwrx.net/forums/mid-atlantic-states/

+ Reply to Thread

Quick Reply Quick Reply

Register Now

Please enter the name by which you would like to log-in and be known on this site.

Please enter a password for your user account. Note that passwords are case-sensitive.

Please enter a valid email address for yourself. We strongly suggest that you stay away from using aol, yahoo, msn, and hotmail accounts. Sometimes the mail server blocks the emails from our server. As a result you will not receive any notifications including the confirmation email.

Please select your insurance company (Optional)

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.


Posting Permissions

  • You may post new threads
  • You may post replies
  • You may not post attachments
  • You may not edit your posts
  •