Knock?
+ Reply to Thread
Results 1 to 4 of 4

This is a discussion on Knock? within the General Maintenance, Troubleshooting & Accidents. forums, part of the Tech & Modifying & General Repairs category; I know this is a Legacy GT. But very similar engines. Hey guys. I've had my 2006 Legacy GT w/ ...

  1. #1
    Registered User
    Join Date
    Apr 2015
    Posts
    2

    Knock?

    I know this is a Legacy GT. But very similar engines.

    Hey guys. I've had my 2006 Legacy GT w/ 5MT for a year now... 170,000 miles on it. Still runs like a champ. Zero issues (just screwed my self) except for this "issue". I'll start with my mods first....

    Grimmspeed Uppipe
    Grimmspeed Downpipe (catted)
    Straight pipe (mufflers and resonator replaced with pipe)
    Cobb Intake + box
    Infamous Performance Turbo Oil Feed Line
    Access port V3 w/ Cobb's OTS Stage 2 +SF 93 Octane Map
    SouthBend Stage 3 clutch w/ WRX flywheel.

    On to the issue.
    I noticed one day (several weeks after I did the mufflers and resonator) that I started to get some readings on my knock feedback. Ever since then I've been getting reading every now and then. Some higher. I see it taking off from a stop (nothing remotely hard) to a short WOT pull on the highway. It happens often and can almost replicate anytime I want.

    Thinks I have done to troubleshoot.
    Different gas stations (maybe bad fuel)
    Used the 91 Octane map with -5 timing set on adjustments
    Tried using octane booster to see if that would help at all... Nothing..
    I've reset the ecu several times

    Everything I've done doesn't change anything... I'm hoping its nothing mechanically wrong with the engine..

    I have a couple datalogs one from a stop and the other at WOT. Please let me know if you want something removed and added. Thanks in advanced.

    WOT Datalog
    Taking off
    Last edited by gt350son; 04-02-2015 at 02:36 PM.

  2. Remove Advertisements
    ClubWRX.net
    Advertisements
     

  3. #2
    Master Baiter EJ257's Avatar
    Join Date
    Aug 2007
    Location
    On a stream bank somewhere
    Posts
    20,289
    I Support ClubWRX
    Upload to Google Docs and set to Public
    2005 WRX STi (Mods | Virtual Dyno)

    Resident Tuner @ WTF Tuning

    "Never trust anything that bleeds for a week and lives ..."

    UNYSOC

  4. #3
    Registered User
    Join Date
    Apr 2015
    Posts
    2
    Thank you. That's better. New links updated in first post.

  5. #4
    Registered User
    Join Date
    Jan 2015
    Posts
    109
    How did a little race gas help? Any? And did you do a fuel pressure test yet? How's your fuel filter? How's your injectors doing? And stop resetting your ecu. Leave that be for now. Let it learn and stay learned.
    '09 silver WRX base sedan. Stock-for now...

+ Reply to Thread

Quick Reply Quick Reply

Register Now

Please enter the name by which you would like to log-in and be known on this site.

Please enter a password for your user account. Note that passwords are case-sensitive.

Please enter a valid email address for yourself. We strongly suggest that you stay away from using aol, yahoo, msn, and hotmail accounts. Sometimes the mail server blocks the emails from our server. As a result you will not receive any notifications including the confirmation email.

Please select your insurance company (Optional)

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.


Posting Permissions

  • You may post new threads
  • You may post replies
  • You may not post attachments
  • You may not edit your posts
  •