Blowing up parts? 2002 wrx. ...bov?
+ Reply to Thread
Page 1 of 2 12 LastLast
Results 1 to 15 of 29

This is a discussion on Blowing up parts? 2002 wrx. ...bov? within the General Maintenance, Troubleshooting & Accidents. forums, part of the Tech & Modifying & General Repairs category; So recently I was having lag issues when the boost would kick shortly after the boot between the intercooler and ...

  1. #1
    Registered User drumbeat's Avatar
    Join Date
    Aug 2014
    Posts
    39

    Blowing up parts? 2002 wrx. ...bov?

    So recently I was having lag issues when the boost would kick shortly after the boot between the intercooler and turbo exploded so I got a new boot checked all my lines and did general maintenance during my test drive again lag and the part burst open my bov is also malfunctioning and she won't run any advice on how to repair ?

  2. Remove Advertisements
    ClubWRX.net
    Advertisements
     

  3. #2
    Moderator Donkey's Avatar
    Join Date
    Apr 2005
    Location
    Da boonies
    Posts
    6,152
    I Support ClubWRX
    Holy run on sentence batman......

    http://www.clubwrx.net/forums/genera...-question.html
    Resident Adviser @ WTF Tuning, LLC
    2002 FORESTER S
    1998 FORESTER S




  4. #3
    Registered User drumbeat's Avatar
    Join Date
    Aug 2014
    Posts
    39
    Sorry trying to use my crap phone to post and it's hard to be proper when typing takes you twenty minutes I just want my baby to run and the Subaru shop here didn't know what the problem was

  5. #4
    Registered User 02_Subie's Avatar
    Join Date
    Jun 2014
    Location
    SE Iowa
    Posts
    23
    You say your bov won't work, if the turbo isn't forcing air into the intercooler(you say the boot burst) then there wouldn't be any pressure to open the bov. Did you use hose clamps on your connections?

  6. #5
    Registered User drumbeat's Avatar
    Join Date
    Aug 2014
    Posts
    39
    Yeah made sure everything was tight and back the way it was supposed to this is my first turbo car and I have very little mechanical knowledge when it comes to them

  7. #6
    Registered User drumbeat's Avatar
    Join Date
    Aug 2014
    Posts
    39
    But I did everything the mechanic pointed out from the diag

  8. #7
    Registered User drumbeat's Avatar
    Join Date
    Aug 2014
    Posts
    39
    The way it blew up was like it had a massive load of pressure on it

  9. #8
    Registered User 02_Subie's Avatar
    Join Date
    Jun 2014
    Location
    SE Iowa
    Posts
    23
    How many psi of boost are you running? What kind of blow off valve do you have?

  10. #9
    Registered User drumbeat's Avatar
    Join Date
    Aug 2014
    Posts
    39
    Roughly 12 and greddy rz

  11. #10
    Registered User 02_Subie's Avatar
    Join Date
    Jun 2014
    Location
    SE Iowa
    Posts
    23
    I know a lot of people will tell you an oem bypass valve is your best bet. Blow off valves can cause the car to run rough, but if yours isn't opening or is stuck shut, it could be the cause of your problem.

  12. #11
    Registered User drumbeat's Avatar
    Join Date
    Aug 2014
    Posts
    39
    That's what I was thinking but wanted to get opinions from some experienced people

  13. #12
    Registered User tirerob's Avatar
    Join Date
    Nov 2012
    Location
    bug-eyeing in the Bakken
    Posts
    1,031
    was the car tuned for the aftermarket bpv?

    have you read the big BOV thread yet? it has more info than you can shake a book at. no really, it took me a day to read the hole thing. its huge. mostly, use a factory BPV or major tuning for the aftermarket ones.

    try swapping the stock or A stock bpv back on to it and using or reconnecting the factory re circulation hose to the turbo inlet hose? are your turbo's vacuum control hoses in the right place and the boost pill in the right hose? ummm...did you check for anything that could have plugged the intercooler on the inside(ok now im reaching but hey!) at 12 pounds of boost, the only thing you should be blowing up are speed limits. that is a nice safe boost level 2.5 psi below stock tuning levels. course, factory hoses....
    when my friends come up, i hear, "you sold the camarrrroooh.....HOLY BLEEP A WRX!"
    Ya has that effect on me too.
    Rob

    Where did he go?? http://www.clubwrx.net/forums/builds...ll-thread.html

  14. #13
    zax
    zax is offline
    \_(ツ)_/ zax's Avatar
    Join Date
    Nov 2008
    Location
    Neverland Ranch, Maryland
    Posts
    13,158
    I Support ClubWRX I Support ClubWRX
    Take it to someone that understands the car. Sorry, but even if we could troubleshoot your problem, it sounds like you don't understand the car well enough to identify what to fix...
    2015 CWP WRX STi ... But how did I get roped back into an EJ motor?!
    Zax's utterly unimaginably stock 2015 STi build thread
    Zax's Shaggin' Wagon Build Thread Now tuned for 99% pure Unicorn Jizz!

    Zach | Moderator -- Mid-Atlantic States, Tech & Modifying & General Repairs
    Rollin' with the Bugeye Mafia #302 | N.E.R.D. Subject Zero
    Facebook me here

    Your Mid-A local board: http://www.clubwrx.net/forums/mid-atlantic-states/

  15. #14
    Registered User drumbeat's Avatar
    Join Date
    Aug 2014
    Posts
    39
    Well seems I have a few ideas thanks guys if it still gives me trouble I'll take her to the shop. zax you have a good point but how will I learn if I never try.

  16. #15
    Registered User drumbeat's Avatar
    Join Date
    Aug 2014
    Posts
    39
    I got it six months ago with 225k miles and a really shady aftermarket setup

+ Reply to Thread
Page 1 of 2 12 LastLast

Quick Reply Quick Reply

Register Now

Please enter the name by which you would like to log-in and be known on this site.
If you do not want to register, fill this field only and the name will be used as user name for your post.

Please enter a password for your user account. Note that passwords are case-sensitive.

Please enter a valid email address for yourself. We strongly suggest that you stay away from using aol, yahoo, msn, and hotmail accounts. Sometimes the mail server blocks the emails from our server. As a result you will not receive any notifications including the confirmation email.

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.


Posting Permissions

  • You may post new threads
  • You may post replies
  • You may not post attachments
  • You may not edit your posts
  •