wrx 2010 rad
Page 1 of 2 12 LastLast
Results 1 to 15 of 16

This is a discussion on wrx 2010 rad within the General Maintenance, Troubleshooting & Accidents. forums, part of the Tech & Modifying & General Repairs category; just got back from dealership, they tell me it's a plugged rad... everheats, inside of the rad looks clean, can ...

  1. #1
    Registered User
    Join Date
    Jul 2014
    Location
    kelowna
    Posts
    22

    wrx 2010 rad

    just got back from dealership, they tell me it's a plugged rad... everheats, inside of the rad looks clean, can this be possible? tomorrow i guess ill put on water thru and see what comes out, test the thermostat... dealership had no rad no cap no thermostat, funny place..

    anyhow i was thinking of buying this thing : does this make sense?

    Replacement Radiator 2008 2010 FOR Impreza Manual Transmission 2 5 45119FG030 | eBay

    thanks

  2. Remove Advertisements
    ClubWRX.net
    Advertisements
     

  3. #2
    Registered User
    Join Date
    Jul 2014
    Location
    kelowna
    Posts
    22
    Rad changed, thermostat, rad caps, had prestone tested for hydrocarbon, found nothibg so head gasket is ok had coolant system pressurized so that's OK too... Is it possible the turbo Is cracked and its pressurizing the coolant system???

    sent from nexus

  4. #3
    He simply abides. SD_GR's Avatar
    Join Date
    Jul 2002
    Location
    CA, US
    Posts
    22,579
    I Support ClubWRX
    What were your initial symptoms?
    WRX Info Links, Courtesy TheJ
    The world breaks everyone and afterward many are strong in the broken places. Ernest Hemingway
    I lied. I cheated. I bribed men to cover the crimes of other men. I am an accessory to murder. But the most damning thing of all... I think I can live with it. And if I had to do it all over again - I would. Benjamin Sisko
    DISCLAIMER: Opinions expressed are the author's alone and are inherently worthless.

  5. #4
    Registered User
    Join Date
    Jul 2014
    Location
    kelowna
    Posts
    22
    Coolant would come out into expansion vase slooooowly after 100km would start overheating. Took thermostat out rode 500km not a drop came out. Beat the living **** out of it no problem

    sent from nexus

  6. #5
    He simply abides. SD_GR's Avatar
    Join Date
    Jul 2002
    Location
    CA, US
    Posts
    22,579
    I Support ClubWRX
    So then replacing the thermostat with a known good thermostat hasn't solved the issue?
    WRX Info Links, Courtesy TheJ
    The world breaks everyone and afterward many are strong in the broken places. Ernest Hemingway
    I lied. I cheated. I bribed men to cover the crimes of other men. I am an accessory to murder. But the most damning thing of all... I think I can live with it. And if I had to do it all over again - I would. Benjamin Sisko
    DISCLAIMER: Opinions expressed are the author's alone and are inherently worthless.

  7. #6
    Registered User
    Join Date
    Jul 2014
    Location
    kelowna
    Posts
    22
    Nope nothing has changed

    sent from nexus

  8. #7
    He simply abides. SD_GR's Avatar
    Join Date
    Jul 2002
    Location
    CA, US
    Posts
    22,579
    I Support ClubWRX
    Sorry I don't understand. You stated:

    Took thermostat out rode 500km not a drop came out. Beat the living **** out of it no problem
    .

    So there's no problem?
    WRX Info Links, Courtesy TheJ
    The world breaks everyone and afterward many are strong in the broken places. Ernest Hemingway
    I lied. I cheated. I bribed men to cover the crimes of other men. I am an accessory to murder. But the most damning thing of all... I think I can live with it. And if I had to do it all over again - I would. Benjamin Sisko
    DISCLAIMER: Opinions expressed are the author's alone and are inherently worthless.

  9. #8
    Registered User
    Join Date
    Jul 2014
    Location
    kelowna
    Posts
    22
    Yes! Still the same problem after everything I described I changed earlier!

    sent from nexus

  10. #9
    He simply abides. SD_GR's Avatar
    Join Date
    Jul 2002
    Location
    CA, US
    Posts
    22,579
    I Support ClubWRX
    Try burping the system repeatedly.
    WRX Info Links, Courtesy TheJ
    The world breaks everyone and afterward many are strong in the broken places. Ernest Hemingway
    I lied. I cheated. I bribed men to cover the crimes of other men. I am an accessory to murder. But the most damning thing of all... I think I can live with it. And if I had to do it all over again - I would. Benjamin Sisko
    DISCLAIMER: Opinions expressed are the author's alone and are inherently worthless.

  11. #10
    Registered User
    Join Date
    Jul 2014
    Location
    kelowna
    Posts
    22
    I did lol

    sent from nexus

  12. #11
    Registered User nsibanez's Avatar
    Join Date
    Aug 2012
    Location
    Bristol, CT
    Posts
    1,442
    What was your procedure for burping. These cars have a very specific way

  13. #12
    Registered User
    Join Date
    Jul 2014
    Location
    kelowna
    Posts
    22
    Jack up right front fill let iddle 20 min see fans start stop 5 6 times adding water when goes low pressing on the hoses to move air around

    sent from nexus

  14. #13
    Registered User
    Join Date
    Jul 2014
    Location
    kelowna
    Posts
    22
    Went to the dealer to tell them trouble shooting didnt turn out right, nothing changed after the 2 rad caps, thermostat and rad... Now there saying its the water pump

    sent from nexus

  15. #14
    Registered User nsibanez's Avatar
    Join Date
    Aug 2012
    Location
    Bristol, CT
    Posts
    1,442
    Quote Originally Posted by paascal View Post
    Went to the dealer to tell them trouble shooting didnt turn out right, nothing changed after the 2 rad caps, thermostat and rad... Now there saying its the water pump

    sent from nexus
    Hell if they say it's the w/p and they're wrong I'd raise hell and make them fix whatever it is for free then at that point. What do you have to lose?
    They tell you why they say it's the water pump at all?

  16. #15
    Registered User
    Join Date
    Jul 2014
    Location
    kelowna
    Posts
    22
    They already said they will pay rad if it'd not that... I was at the garage, for 2nd trouble shoot, car was running 104 celc at idle (never did this when rad was full). They revved it to 3krpm temp went down to 92, as soon as they let rpm drop it raised back to 100.. Lower rad hose was cold, would seem pump doesn't flow enough... I thought it could be the turbo that the water jacket it cracket and turbo boost in coolant system by they never saw this ever happening

    sent from nexus

Page 1 of 2 12 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •