Throttle lag
Results 1 to 7 of 7

This is a discussion on Throttle lag within the General Maintenance, Troubleshooting & Accidents. forums, part of the Tech & Modifying & General Repairs category; I just bought a 2002 wrx wagon 2.0l bout a month ago, when I hit the gas it seems to ...

  1. #1
    Registered User
    Join Date
    Jul 2014
    Posts
    2

    Throttle lag

    I just bought a 2002 wrx wagon 2.0l bout a month ago, when I hit the gas it seems to have a lack in power, but then it kicks into full boost. As far as I know it's all stock with 140,000 miles. So pretty sluggish at first. I do not have a boost gauge installed yet. Any I sea on where to start on problem diagnosis?

  2. Remove Advertisements
    ClubWRX.net
    Advertisements
     

  3. #2
    Moderator Donkey's Avatar
    Join Date
    Apr 2005
    Location
    Da boonies
    Posts
    6,150
    I Support ClubWRX
    Welcome to owning a stock turbocharged 4 cylinder.


    Sent from my magic banana...
    Resident Adviser @ WTF Tuning, LLC
    2002 FORESTER S
    1998 FORESTER S




  4. #3
    Registered User nsibanez's Avatar
    Join Date
    Aug 2012
    Location
    Tucson, AZ
    Posts
    1,858
    ^^^^^Sounds like normal turbo lag
    Stinkeye member 520

  5. #4
    OMG WTF MainFrame's Avatar
    Join Date
    Sep 2002
    Location
    Texas, United States
    Posts
    8,288
    I Support ClubWRX I Support ClubWRX
    What exactly is happening that leads you to believe there is a problem?

  6. #5
    Registered User
    Join Date
    Jul 2014
    Posts
    2
    There's no power on take off. Bogs when gas is applied

  7. #6
    Registered User nsibanez's Avatar
    Join Date
    Aug 2012
    Location
    Tucson, AZ
    Posts
    1,858
    Just to clarify, you're not trying to go WOT with 1k rpm or less right?
    Stinkeye member 520

  8. #7
    Registered User Monk_Knight's Avatar
    Join Date
    Aug 2010
    Location
    Colorado
    Posts
    550
    If you are trying to get much power out of the car below 3000 rpms and it feels sluggish... that's pretty normal. It's a very small engine and doesn't make much power til the turbo spools.

    Now if you are punching it at 4500 and it bogs before taking off... then you might have a problem.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •