Oh No...Check Engine Light, new WRX15
+ Reply to Thread
Results 1 to 7 of 7

This is a discussion on Oh No...Check Engine Light, new WRX15 within the General Maintenance, Troubleshooting & Accidents. forums, part of the Tech & Modifying & General Repairs category; Dear WRXers, Wanted to get any thoughts and perspective. I was driving home from work today, stopped at a stop ...

  1. #1
    Registered User
    Join Date
    Jul 2014
    Posts
    7

    Oh No...Check Engine Light, new WRX15

    Dear WRXers,

    Wanted to get any thoughts and perspective. I was driving home from work today, stopped at a stop light, and when I started out in first I noted that it didn't seem that I had any power. I pulled over, turned off the car, restarted the engine and presto had the check engine light on. Called the dealer and unfortunately they can't get me in until Wed. However, they have told me that as long as the check engine light isn't flashing I'm ok to drive until they can get it in. Also noticed faint smell on vehicle exit, but that didn't seem to persist. Belts and engine look fine, no fluid leaks, etc.

    After about an hour I went out to the store, as you all know on the new WRXs when you step on the accelerator regardless of gear the car feels like it just wants to fly away. This isn't happening for me now, in particular the punch that I used to get in first gear just isn't there, and even in higher gears acceleration is ok...but not always smooth. Turbo gauge looks like it is showing boost, but honestly I'm not great at understanding what I should be looking for...just like to look at On top of that, the check engine light is now gone.

    I should also add, this car is 2 months old, and is basically driven around town like a thoroughbred being led to the track, in town there just isn't space or safety in punching int..

    Few questions:

    1) Isn't the check engine light a binary dumb light that basically once triggered stays on until reset by dealer? More worried about it not being on any more than comforted in having it gone.
    2) Given that the light is now off, and never flashed, do we think "safe to drive" until you get in on Wed is reasonable?
    3) Any guesses as to what I might be looking at?

    Thanks for your thoughts,

  2. Remove Advertisements
    ClubWRX.net
    Advertisements
     

  3. #2
    Registered User Aaronw9's Avatar
    Join Date
    Oct 2012
    Location
    Seattle
    Posts
    29
    If the code comes back on before Wednesday go to an autozone or other auto store and ask for a code reader. You can find out what the code is.

  4. #3
    Registered User
    Join Date
    Jul 2014
    Posts
    7
    Thanks for the thought and input...now I wait for the illusive light.

  5. #4
    Registered User
    Join Date
    Jan 2014
    Posts
    10
    For $20 I think everyone should have one of these. I keep one in my glovebox and have used it on friends and family members cars as well. Just download an App like Torque and you can read, clear codes, and get lots of other info....

    Amazon.com: BAFX Products - Bluetooth OBD2 scan tool - For check engine light & diagnostics - Android ONLY: Automotive

  6. #5
    Registered User cogito's Avatar
    Join Date
    Jul 2013
    Location
    Southern NH
    Posts
    365
    Quote Originally Posted by montanajer View Post
    Thanks for the thought and input...now I wait for the illusive light.
    No need to wait for the light. You can still get the codes that were thrown. Has performance improved since the check engine light went off?????
    2013 WRX Dark Grey Hatch
    1974 Datsun 260z Stroker

  7. #6
    Registered User
    Join Date
    May 2014
    Location
    Bozeman, Montana, United States
    Posts
    3
    Engine performance is still very sluggish, I wonder if the CEL flipped it into a safe engine mode and that's why I'm seeing the problem with acceleration. The 15 always wants to take off when you push on the accelerator regardless of gear, and now the acceleration is slower.

  8. #7
    Registered User cogito's Avatar
    Join Date
    Jul 2013
    Location
    Southern NH
    Posts
    365
    Sounds likely that it's in limp mode. I'd take to the dealer pronto, you can still pull the codes for curiosity sake prior to dealer. But since your under warranty let them fiddle with it, and make sure your compensated for any inconvenience. Been there done it, only with a Ford. Get er done.
    2013 WRX Dark Grey Hatch
    1974 Datsun 260z Stroker

+ Reply to Thread

Quick Reply Quick Reply

Register Now

Please enter the name by which you would like to log-in and be known on this site.
If you do not want to register, fill this field only and the name will be used as user name for your post.

Please enter a password for your user account. Note that passwords are case-sensitive.

Please enter a valid email address for yourself. We strongly suggest that you stay away from using aol, yahoo, msn, and hotmail accounts. Sometimes the mail server blocks the emails from our server. As a result you will not receive any notifications including the confirmation email.

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.


Posting Permissions

  • You may post new threads
  • You may post replies
  • You may not post attachments
  • You may not edit your posts
  •