03 WRX will only run on starting fluid after rebuild
Results 1 to 6 of 6

This is a discussion on 03 WRX will only run on starting fluid after rebuild within the General Maintenance, Troubleshooting & Accidents. forums, part of the Tech & Modifying & General Repairs category; I bought an 03 wrx and it needed the heads redone and a new t-belt because a bearing locked up. ...

  1. #1
    Registered User
    Join Date
    Jul 2014
    Posts
    3

    03 WRX will only run on starting fluid after rebuild

    I bought an 03 wrx and it needed the heads redone and a new t-belt because a bearing locked up. I had the heads sent out to the machine shop and all new timing components put on. Everything is done right that I can see and the car will only run on starting fluid, it does seem to run good when is starts just for some reason the car isnt getting fuel. Im not sure what the issue is but Im quite sure I have all the vaccum lines hooked up and I doubt the CTS is bad since it was fine before the swap.

    I did pull the entire motor and Im not sure If I may have missed something in the reinstall. Its my first wrx motor pull but im very familiar with car in general and I have tried all the usual stuff to try and get it running. Im just wandering if there is something simple that I forgot or something I missed.


    any help is greatly appreciated, thanks

  2. Remove Advertisements
    ClubWRX.net
    Advertisements
     

  3. #2
    Moderator Donkey's Avatar
    Join Date
    Apr 2005
    Location
    Da boonies
    Posts
    6,036
    I Support ClubWRX
    You checked fuel pressure and the pump primes when you turn the key to the "on" position? You don't have a DTC?
    Resident Adviser @ WTF Tuning, LLC
    2002 FORESTER S
    1998 FORESTER S




  4. #3
    Registered User
    Join Date
    Jul 2014
    Posts
    3
    Quote Originally Posted by Donkey View Post
    You checked fuel pressure and the pump primes when you turn the key to the "on" position? You don't have a DTC?
    The fuel pump works and is turning on and the injectors are pulsing.

  5. #4
    Moderator Donkey's Avatar
    Join Date
    Apr 2005
    Location
    Da boonies
    Posts
    6,036
    I Support ClubWRX
    Does it have a DTC?
    Resident Adviser @ WTF Tuning, LLC
    2002 FORESTER S
    1998 FORESTER S




  6. #5
    Registered User
    Join Date
    Jul 2014
    Posts
    3
    No DTC's I have checked several times

  7. #6
    Registered User pete25r's Avatar
    Join Date
    Jan 2011
    Location
    Maryland
    Posts
    486
    When I put my fuel pump in it made noises like it was primed and good to go but it wasn't. Car would just turn over and not fire. I didn't get any DTCs either.
    I had to prime it by removing the line that comes off of the top of the tank. That sucker will squirt pretty good once you disconnect it from the line to the engine bay. I had the line resting in an old plastic soda bottle, jumped out and sprayed the backseat. After that I was sure it was pushing fuel down the line.

    I'd pull off the fuel line in the engine bay, from the tank/supply side of the fuel filter(that'll cut out most restriction without having to pull your seats out). Turn on the car, not crank, and see if fuel squirts out. If it doesn't squirt, off and on until it does. Over 4 or so on/off cycles you might have another problem.
    N.E.R.D. # 3.579545 MHz

    Bugeye Mafia v 2.0 # 371

    pete25r's build

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •