2009 WRX Sedan Recirc Fan Light Blinking
+ Reply to Thread
Results 1 to 4 of 4

This is a discussion on 2009 WRX Sedan Recirc Fan Light Blinking within the General Maintenance, Troubleshooting & Accidents. forums, part of the Tech & Modifying & General Repairs category; Ok, As I start to use this forum more and more, I find more and more answers to stupid questions ...

  1. #1
    2009 WRX Sedan Blammo's Avatar
    Join Date
    Dec 2012
    Location
    British Columbia, Canada
    Posts
    150
    I Support ClubWRX

    2009 WRX Sedan Recirc Fan Light Blinking

    Ok,

    As I start to use this forum more and more, I find more and more answers to stupid questions I might have. LOL!!!

    However, are there ANY other owners out there who experience the "Recirculation Fan Light" blinking about 10 times upon a cold start in the morning. It is the weirdest thing. Makes no sense.

    I am referring to the dial on the left of the three. It has the push button that activates or deactivates the recirculation function of your climate controls.

    I have seen this blinking light behavior maybe about 10 times since I have owned the car. (December 2012). It blinks on and off about 10 times while the car is warming up.

    I have no idea what it is, and of course, Subaru will not help or identify as they say if the problem doesn't present itself then there is nothing wrong. Fair enough I guess.

    I guess its one of those Subaru things I will never come to understand.

    Thanks,

    Blammo

  2. Remove Advertisements
    ClubWRX.net
    Advertisements
     

  3. #2
    2009 WRX Sedan Blammo's Avatar
    Join Date
    Dec 2012
    Location
    British Columbia, Canada
    Posts
    150
    I Support ClubWRX
    For real?

    Am I the only one with an 09 experiencing this weirdness?

  4. #3
    Registered User
    Join Date
    Nov 2012
    Posts
    2
    I have a 2009 wrx and I've noticed mine does the same thing. Unfortunately, I have no idea why.

    But the button still works so I guess there's nothing wrong...hopefully

  5. #4
    2009 WRX Sedan Blammo's Avatar
    Join Date
    Dec 2012
    Location
    British Columbia, Canada
    Posts
    150
    I Support ClubWRX
    yea...my button still works.

    I cant help but wonder what Subie is trying to say to me!!!

    oh well...it actually happened today...but only blinked 4 times. weird

+ Reply to Thread

Quick Reply Quick Reply

Register Now

Please enter the name by which you would like to log-in and be known on this site.
If you do not want to register, fill this field only and the name will be used as user name for your post.

Please enter a password for your user account. Note that passwords are case-sensitive.

Please enter a valid email address for yourself. We strongly suggest that you stay away from using aol, yahoo, msn, and hotmail accounts. Sometimes the mail server blocks the emails from our server. As a result you will not receive any notifications including the confirmation email.

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.


Posting Permissions

  • You may post new threads
  • You may post replies
  • You may not post attachments
  • You may not edit your posts
  •