Brand new 2015 WRX Engine Light and Blinking Cruise Control !? - Page 2
+ Reply to Thread
Page 2 of 2 FirstFirst 12
Results 16 to 20 of 20

This is a discussion on Brand new 2015 WRX Engine Light and Blinking Cruise Control !? within the General Maintenance, Troubleshooting & Accidents. forums, part of the Tech & Modifying & General Repairs category; my lights went off after i checked the gs cap and the fluids took it for a drive and drove ...

  1. #16
    Registered User basqueo81's Avatar
    Join Date
    Jun 2014
    Location
    Mtn.Home Idaho
    Posts
    20
    my lights went off after i checked the gs cap and the fluids took it for a drive and drove fine. ended up driving it up to the dealer and they ran it with there computers and told me there is something wrong with my computer for the throttle. i thought it ran fine but they said its not. so ended getting a loaner. not to happy got family from out of town and wanted to show it off a bit. they said there waiting for subaru inc. to call they said someone has to fly in from there to update the computer. im not sure how much i believe all that. this sucks.

  2. Remove Advertisements
    ClubWRX.net
    Advertisements
     

  3. #17
    Registered User
    Join Date
    Jun 2014
    Posts
    9
    Quote Originally Posted by basqueo81 View Post
    my lights went off after i checked the gs cap and the fluids took it for a drive and drove fine. ended up driving it up to the dealer and they ran it with there computers and told me there is something wrong with my computer for the throttle. i thought it ran fine but they said its not. so ended getting a loaner. not to happy got family from out of town and wanted to show it off a bit. they said there waiting for subaru inc. to call they said someone has to fly in from there to update the computer. im not sure how much i believe all that. this sucks.
    Wow that's a bummer. When the dealership told me the computer codes came back as clutch and air conditioning, it didn't convince me that was real as both work absolutely fine. And the guy telling me this at the dealership seemed confused as well, but as with you - they were waiting to hear back from Subaru inc.---I had to get back to work so they ended up just letting me drive off since the warning lights turned off when gas cap was tightened. Both the air conditioner and clutch work great, I have been using both for about 200 more miles now.. highway and city.

    I wonder if the gas cap issue can trigger other abnormalities with computer diagnostics.

    Either way - I plan to go back to the original dealership that I got car from (it's a bit of a further drive, 60 miles) for my first oil change - probably around 1,500 miles to be on the safe side - and tell them what happened. Maybe they will be more informed on such issues.

    Will keep updating soon as I get more info.

    Thanks for the info Basqueo81

  4. #18
    Registered User
    Join Date
    Aug 2014
    Posts
    10

    Cruise Control Check Engine problem

    It happened to me today! 2015 wrx with 3k miles. I was coming to a stop and the engine started revving to 3k. It wouldn't stop. The check engine came on and the cruise control dash indicator started flashing. Then when the traffic light turned green, I could barely accelerate over to the curb. It felt like the clutch was slipping. I shut it off and called my Subaru dealer. They told me to bring it right in. It's a known problem and there is a software fix. It took them an hour to fix that and the gas door sticking problem. That's another known 2015 wrx defect. Gas door started sticking right after my 1k check. I had to use a credit card to pop it open. There is a kit that fixes it.


    Quote Originally Posted by wrx2015 View Post
    Greetings all,

    I have owned a 2002 Impreza WRX for 8 years and rode her to the ground.

    I recently picked up a brand new 2015 WRX, I drove it out of dealership with 7 miles!

    I know you are suppose to take it easy for first 1,000-5,000 miles .. synthetic oil, hi octane gas, oil change after first 1,000-3,000 miles.. etc.

    Riding around, awesome ride. Now it has 200 miles, I've owned it for maybe 5 days. Haven't abused it at all. I was riding to work then suddenly I couldn't accelerate, but it kept the revs around 2,500 even when I took my foot off gas. Luckily I was going around 30 mph, so I pull over to a gas station, put it in neutral (still revving) and turn it off.

    I let it rest for a few minutes, turn it back on without issue, however... the Cruise Control light was blinking (I made sure cruise control is off/canceled multiple times) - and Check Engine light is on!!! Barely 200 miles and I been taking it easy. The Engine temperature is normal (just less then half) , oil is full, coolant full, etc.

    I made it to work but now pretty annoyed that I have to take my brand new subaru wrx to the Subaru shop (according to the owners manual - keep speeds low and go to shop asap)

    Anyone else had similar issues? I will advise what the issue is once I get my car back...
    Last edited by Trypt; 08-23-2014 at 05:54 PM.

  5. #19
    Registered User
    Join Date
    Aug 2014
    Posts
    8
    Quote Originally Posted by Trypt View Post
    It happened to me today! 2015 wrx with 3k miles. I was coming to a stop and the engine started revving to 3k. It wouldn't stop. The check engine came on and the cruise control dash indicator started flashing. Then when the traffic light turned green, I could barely accelerate over to the curb. It felt like the clutch was slipping. I shut it off and called my Subaru dealer. They told me to bring it right in. It's a known problem and there is a software fix. It took them an hour to fix that and the gas door sticking problem. That's another known 2015 wrx defect. Gas door started sticking right after my 1k check. I had to use a credit card to pop it open. There is a kit that fixes it.
    Wow I'm really looking forward to picking up my car on Wednesday now..I have a 16 hr drive home with it..hopefully none of this crap happens. Thanks for the info

  6. #20
    Registered User Bontchimuz's Avatar
    Join Date
    Apr 2014
    Location
    Rye, NH
    Posts
    136
    Hmmmm maybe its a WRX only issue? I am interested in what develops here and pray I dont experience it on my STi...Good luck and keep us posted.


    2015 WRX STi
    World Rally Blue

    Smaug is his name and he has a friggin dragon wing.
    Boom Cannon

+ Reply to Thread
Page 2 of 2 FirstFirst 12

Quick Reply Quick Reply

Register Now

Please enter the name by which you would like to log-in and be known on this site.
If you do not want to register, fill this field only and the name will be used as user name for your post.

Please enter a password for your user account. Note that passwords are case-sensitive.

Please enter a valid email address for yourself. We strongly suggest that you stay away from using aol, yahoo, msn, and hotmail accounts. Sometimes the mail server blocks the emails from our server. As a result you will not receive any notifications including the confirmation email.

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.


Posting Permissions

  • You may post new threads
  • You may post replies
  • You may not post attachments
  • You may not edit your posts
  •