Squeaky clutch pedal??
Results 1 to 8 of 8

This is a discussion on Squeaky clutch pedal?? within the General Maintenance, Troubleshooting & Accidents. forums, part of the Tech & Modifying & General Repairs category; Hello everyone, I am unsure if I am posting this in the right sub-forum or not but here I go ...

  1. #1
    Registered User
    Join Date
    May 2014
    Location
    Des Plaines, IL.
    Posts
    7

    Squeaky clutch pedal??

    Hello everyone,

    I am unsure if I am posting this in the right sub-forum or not but here I go anyways:

    So I upgraded my clutch last summer to a stage 3 clutch and since about mid-winter my clutch pedal started to squeak (when depressing and releasing it). I spoke to the mechanic at the dealership one day when I got my oil changed and he advised that since I upgraded the clutch it has caused the spring on the pedal to wear down ( not the exact words but I hope you get the idea). Now was he just pulling my leg or is that an actual problem that happens when you upgrade the clutch?

    Also if it is a real problem where can I get a new or upgraded clutch pedal spring?? Would any aftermarket shop or parts store/website have them?

    Any and all help will be highly appreciated!!

    Thanks in advance!!

  2. Remove Advertisements
    ClubWRX.net
    Advertisements
     

  3. #2
    Registered User nsibanez's Avatar
    Join Date
    Aug 2012
    Location
    Bristol, CT
    Posts
    1,430
    What year car?
    Basically every 08-10 model have broken clutch welds. Maybe the layer 3rd gens too, not sure

    Sent from my SCH-I545 using Tapatalk

  4. #3
    Registered User
    Join Date
    May 2014
    Location
    Des Plaines, IL.
    Posts
    7
    I have an '08, would the broken weld be something i can fix myself or would I need to bring it to a shop? Also the broken weld isn't going to cause my clutch pedal to break off will it?

  5. #4
    Registered User nsibanez's Avatar
    Join Date
    Aug 2012
    Location
    Bristol, CT
    Posts
    1,430
    You can use a nut and bolt to help hold it in place but the best thing you can do is get it re welded. The firewall is still going to flex, you're still losing pedal force to flex the firewall and it shouldn't break the pedal off. The creaking will eventually turn to popping. Even with all 6 welds broken you can still shift it's just very annoying and just a bad feel period. You're not getting as much force into disengaging the clutch.
    I have mine held together nut and bolt style but it requires you to drill through the broken welds in order to fit a bolt through and ypu more then likely need to remove the dash.
    Not to mention subaru won't be any help much

    Sent from my SCH-I545 using Tapatalk

  6. #5
    Registered User
    Join Date
    May 2014
    Location
    Des Plaines, IL.
    Posts
    7
    Thanks!! I will hopefully have some time this weekend to give it a look to see if/how I will be able to get it done.

  7. #6
    2009 WRX Sedan Blammo's Avatar
    Join Date
    Dec 2012
    Location
    British Columbia, Canada
    Posts
    134
    I Support ClubWRX
    I know this thread is a few weeks old...

    I have an 09 WRX Sedan that has a squeaky clutch pedal also. The squeak evolved into creaking and then popping and then it went away for a long while. It is now just an ever present noise. With the stereo off...sounds like a door opening/closing slowly.

    It is so annoying and makes me wonder about quality control at Subaru's plant in Japan or wherever it is made.

    Honestly though, I have never felt a difference in clutch operation at all. It still feels and functions the same as when I bought it. Weird right? I have simply ignored the noise. I inspected the pedal as best I could and found no problems. I keep using it. I suppose if its a ticking timebomb of some sort...time will bomb me when its ready. LOL!!

  8. #7
    Registered User
    Join Date
    Jun 2014
    Posts
    4
    I got it fixed under warranty... It was a long fight, but it got done. They welded a steel plate behind the firewall.

  9. #8
    2009 WRX Sedan Blammo's Avatar
    Join Date
    Dec 2012
    Location
    British Columbia, Canada
    Posts
    134
    I Support ClubWRX
    Well...thanks for chiming in boogieman065.

    After reading your post, I felt inspired to pick a bone with SOC (im Canadian)....and see where it gets me. Since I am under warranty technically and my car is still bone stock.

    I go in on Wednesday to the very dealer that sold me the car. I have a bumper to bumper warranty on it. I guess I may have to put off AP, Stage 2 and exhaust until I get this clutch pedal fixed. What a bummer.

    Don't know why I had to read your story to consider exercising my warranty. I am a bit of a tard in this regard.

    I am sure if I went in with Stage 2 and exhaust etc....they will try to blame the new exhaust for breaking my clutch pedal.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •