2014 WRX Stage 2 Datalog Review
+ Reply to Thread
Results 1 to 6 of 6

This is a discussion on 2014 WRX Stage 2 Datalog Review within the General Maintenance, Troubleshooting & Accidents. forums, part of the Tech & Modifying & General Repairs category; Hey guys I have been Stage 2 for about a month now on my 2014 WRX. Just so you guys ...

  1. #1
    Registered User
    Join Date
    Dec 2013
    Posts
    104

    2014 WRX Stage 2 Datalog Review

    Hey guys I have been Stage 2 for about a month now on my 2014 WRX. Just so you guys know the car has the Cobb DP, SF, and Invidia Catback. Can you guys over look my datalog and tell me if you guys think everything look ok? I did a 3rd gear pull. Thanks for your guys help.

    https://docs.google.com/spreadsheets...gid=1917462867

  2. Remove Advertisements
    ClubWRX.net
    Advertisements
     

  3. #2
    Registered User anpato's Avatar
    Join Date
    Jun 2012
    Posts
    494
    Just pulls a little timing on the bottom end but thats normal, overall looks good. Im assuming your using an access port?
    2013 SWP WRX Sedan
    Hillside, NJ
    Invidia Catless Downpipe, Custom Short Ram Intake, Self Tuned Using ECU Flash, Romraider and Tactrix

  4. #3
    Registered User
    Join Date
    Dec 2013
    Posts
    104
    Thanks for looking at it and yeah I am.

  5. #4
    Registered User speedtown's Avatar
    Join Date
    Feb 2012
    Location
    VT
    Posts
    181
    hmm I'm surprised that you're not hitting more boost but it looks safe just a little knock and it's only 1.4 so nothing to get worked up about. Have you ever logged your injector duty cycle? I know before I switched to my LWG map I was overboosting and maxing out my IDC and hitting fuel cut. I doubt by looking at your log that you are in danger of it but it's something to check once in a while.

  6. #5
    Master Baiter EJ257's Avatar
    Join Date
    Aug 2007
    Location
    On a stream bank somewhere
    Posts
    19,862
    I Support ClubWRX
    Have you checked for any leaks?
    2005 WRX STi (Mods | Virtual Dyno)

    Resident Tuner @ WTF Tuning

    "Never trust anything that bleeds for a week and lives ..."

    UNYSOC

  7. #6
    Registered User
    Join Date
    Dec 2013
    Posts
    104
    My car normally hits around 16.5 PSI but for some reason it wasn't. I have not done a injector duty cycle. Does it look like my car is has a leak?

+ Reply to Thread

Quick Reply Quick Reply

Register Now

Please enter the name by which you would like to log-in and be known on this site.
If you do not want to register, fill this field only and the name will be used as user name for your post.

Please enter a password for your user account. Note that passwords are case-sensitive.

Please enter a valid email address for yourself. We strongly suggest that you stay away from using aol, yahoo, msn, and hotmail accounts. Sometimes the mail server blocks the emails from our server. As a result you will not receive any notifications including the confirmation email.

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.


Posting Permissions

  • You may post new threads
  • You may post replies
  • You may not post attachments
  • You may not edit your posts
  •