Not sure if this is a problem or not...
Results 1 to 2 of 2

This is a discussion on Not sure if this is a problem or not... within the General Maintenance, Troubleshooting & Accidents. forums, part of the Tech & Modifying & General Repairs category; It may just be me being crazy. So, my car has about 23k miles on it. I haven't had any ...

  1. #1
    Registered User Sanala's Avatar
    Join Date
    Apr 2012
    Location
    Colorado
    Posts
    57

    Not sure if this is a problem or not...

    It may just be me being crazy. So, my car has about 23k miles on it. I haven't had any engine problems ever, and I suppose I still really don't. I was just curious on something, however...

    My engine is very loud. I wish I could post a video, but all I can hear is like a clicking/whirling sort of belt-like noise. I took my car in within the last two months to have it inspected, Subaru people said nothing was really wrong.

    Should I be worried? Or am I insane?

  2. Remove Advertisements
    ClubWRX.net
    Advertisements
     

  3. #2
    MAINEiac 11blackSTi's Avatar
    Join Date
    Nov 2012
    Location
    Portland, ME
    Posts
    2,755
    I Support ClubWRX
    Is it a consistent sound, or does it get worse under certain conditions? Worse when cold, under heavy load, etc? If you do have a problem the good thing is you are still under factory warranty, so any issues should be covered. Our cars are not the quietest cars ever made, so could be perfectly normal. Unfortunately it is really difficult to help without more details. Might be worth trying to post up a video if at all possible. If it were me and I was convinced something was wrong (car noticeably got louder out of nowhere, to the point where I was concerned), and I was still under warranty, I would bring it to another dealer and get their thoughts on it.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •