Help!! Wrx loses oil pressure and dies
+ Reply to Thread
Results 1 to 3 of 3

This is a discussion on Help!! Wrx loses oil pressure and dies within the General Maintenance, Troubleshooting & Accidents. forums, part of the Tech & Modifying & General Repairs category; Hi I have an 02 wrx that I just got fully rebuilt a couple months ago and the car runs ...

  1. #1
    Registered User
    Join Date
    Mar 2014
    Posts
    2

    Help!! Wrx loses oil pressure and dies

    Hi I have an 02 wrx that I just got fully rebuilt a couple months ago and the car runs great but once it's gets to operating temp. and I push in the clutch and put into neutal the rpm's just keep dropping along with the oil pressure and doesn't idle and the car dies but starts back up and runs fine. But if I idle step the car myself it finds idle and oil pressure goes to normal and stays there. The people that worked on my car said it had to do with the tune and the idle stepper needed to be raised but I'm not sure if they're right. So if someone with some insight could help me that would be great so if you have any ideas what the problem could be please let me know

  2. Remove Advertisements
    ClubWRX.net
    Advertisements
     

  3. #2
    UnBanned Sinister's Avatar
    Join Date
    Nov 2006
    Location
    Denver Metro Area
    Posts
    17,641
    I Support ClubWRX
    The idle can be adjusted in the map. Is it a custom tune?
    Kevin
    Moderator
    Sinister's Blowoff Valve FAQ
    WRX Gas Mileage FAQ
    Sinister's Progress Thread - 430whp 429wtq - Sold
    Firearms Enthusiasts Thread

    The Sheriff's Star at the bottom left corner rates a user's reputation.
    If you found a user's post to be helpful or quite the opposite, please make it known to them by clicking the Star!

  4. #3
    Registered User
    Join Date
    Mar 2014
    Posts
    2
    Quote Originally Posted by Sinister View Post
    The idle can be adjusted in the map. Is it a custom tune?
    Yeah it's a custom tune and it's junk and I knew I was gonna have to have it retuned anyways cause I'm only running 245whp instead of being around 400

+ Reply to Thread

Quick Reply Quick Reply

Register Now

Please enter the name by which you would like to log-in and be known on this site.
If you do not want to register, fill this field only and the name will be used as user name for your post.

Please enter a password for your user account. Note that passwords are case-sensitive.

Please enter a valid email address for yourself. We strongly suggest that you stay away from using aol, yahoo, msn, and hotmail accounts. Sometimes the mail server blocks the emails from our server. As a result you will not receive any notifications including the confirmation email.

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.


Posting Permissions

  • You may post new threads
  • You may post replies
  • You may not post attachments
  • You may not edit your posts
  •