Turbo troubles.....i think.... please help!!!
Results 1 to 11 of 11

This is a discussion on Turbo troubles.....i think.... please help!!! within the General Maintenance, Troubleshooting & Accidents. forums, part of the Tech & Modifying & General Repairs category; I have a 06 wrx with some major issues. I was on the freeway the other day and it seemed ...

  1. #1
    Registered User
    Join Date
    Feb 2014
    Posts
    3

    Unhappy Turbo troubles.....i think.... please help!!!

    I have a 06 wrx with some major issues. I was on the freeway the other day and it seemed the turbo just cut out. the power lose was basically cut in half. kind of like driving a non turbo 2.5 liter. i couldn't hear the turbo winding up at all. i got it home and decided to pull off the intercooler. inside the intercooler was a brownish tan liquid. it was the turbo along with the intake manifold. i don't know if that means i have a seal busted somewhere or what??? please help this is my first subaru and don't want to regret this purchase. when i bought it, it had an spt aftermarket intake and ehaust system. if you have any ideas please respond.

  2. Remove Advertisements
    ClubWRX.net
    Advertisements
     

  3. #2
    Registered User wreckingball man's Avatar
    Join Date
    Jul 2012
    Location
    Rocky Top
    Posts
    2,272
    Do you have any logs with that intake?

    Oil film in there is normal. Some other things to check are all the boost control lines. Did it smoke pretty bad or anything? If it's burning oil then you would see it in the downpipe and the car would smoke. Do you have a boost gauge? Not really sure where to start you off. Hopefully some other people will chime in. It's usually pretty slow on the weekend. But I'll help you as best I can.

    Do you have an owner's manual by chance?

  4. #3
    MAINEiac 11blackSTi's Avatar
    Join Date
    Nov 2012
    Location
    Portland, ME
    Posts
    2,730
    I Support ClubWRX
    Quote Originally Posted by killa hurtz View Post
    I have a 06 wrx with some major issues. I was on the freeway the other day and it seemed the turbo just cut out. the power lose was basically cut in half. kind of like driving a non turbo 2.5 liter. i couldn't hear the turbo winding up at all. i got it home and decided to pull off the intercooler. inside the intercooler was a brownish tan liquid. it was the turbo along with the intake manifold. i don't know if that means i have a seal busted somewhere or what??? please help this is my first subaru and don't want to regret this purchase. when i bought it, it had an spt aftermarket intake and ehaust system. if you have any ideas please respond.
    How much oil did you find in inside the intercooler/manifold area? Did any check engine light come on at all? Also, how did the car respond after you put the intercooler back on, still no boost?

  5. #4
    Registered User W_R_XTC's Avatar
    Join Date
    May 2012
    Location
    brunswick ohio
    Posts
    106
    loss of power, brown frothy oil in intercooler/intake/turbo... turbo went kaboom. pull the down pipe, look at the exhaust impeller of the turbo. its probably going to either be resting in the cat, or no longer attached to the impeller shaft. ive done 3 on customer cars in the last 2 weeks.

  6. #5
    Moderator Donkey's Avatar
    Join Date
    Apr 2005
    Location
    Da boonies
    Posts
    5,992
    I Support ClubWRX
    Quote Originally Posted by killa hurtz View Post
    I have a 06 wrx with some major issues. I was on the freeway the other day and it seemed the turbo just cut out. the power lose was basically cut in half. kind of like driving a non turbo 2.5 liter. i couldn't hear the turbo winding up at all. i got it home and decided to pull off the intercooler. inside the intercooler was a brownish tan liquid. it was the turbo along with the intake manifold. i don't know if that means i have a seal busted somewhere or what??? please help this is my first subaru and don't want to regret this purchase. when i bought it, it had an spt aftermarket intake and ehaust system. if you have any ideas please respond.
    Does it have a turbo back or cat back exhaust? Unless you have a catch can system or an air/oil separator you will always have some sort of oil in the intake tract. Do you have a boost gauge?
    Resident Adviser @ WTF Tuning, LLC
    2002 FORESTER S
    1998 FORESTER S




  7. #6
    Registered User
    Join Date
    Feb 2014
    Posts
    3
    so is this a pretty easy fix? im on a tight budget right now so im planning on just putting back on the original turbo, would like to upgrade but dont have the $$$. i have a pretty good mechanical sense so it shouldnt be too hard for me to pull the old turbo off and install a new one, but im not sure if i need to have it tuned afterwards or what? any info would be helpful thanks again.

  8. #7
    Moderator Donkey's Avatar
    Join Date
    Apr 2005
    Location
    Da boonies
    Posts
    5,992
    I Support ClubWRX
    What do you mean by original turbo? Are both turbo's stock? All you mention for mods were an intake and exhaust.
    Resident Adviser @ WTF Tuning, LLC
    2002 FORESTER S
    1998 FORESTER S




  9. #8
    Registered User Impreza2.0's Avatar
    Join Date
    Nov 2008
    Location
    Maine
    Posts
    899
    It will be very hard to help if you don't answer the first questions,
    does your car have a boost gauge in it's instrument cluster or anywhere else on the dashboard?
    how much oil was in the intercooler/throttle/intake manifold area?
    describe in detail how it cut out. you were accelerating? slowing down? leaving a fresh green light with some force behind you? more details, more we can tell you.

    this information is very important.
    there are very expensive and complicated fixes for a potentially serious issue

    or

    there is a cheap quick fix that will have you rolling in no time.......

    please tell us.

    weekends suck alone with a broken car. we know that.

  10. #9
    Registered User
    Join Date
    Feb 2014
    Posts
    3
    i have no boost gauge and there was very little oil in the intercooler/throttle/intake area. i was accelerating when i felt the huge power lose.

  11. #10
    Moderator Donkey's Avatar
    Join Date
    Apr 2005
    Location
    Da boonies
    Posts
    5,992
    I Support ClubWRX
    Quote Originally Posted by killa hurtz View Post
    i have no boost gauge and there was very little oil in the intercooler/throttle/intake area. i was accelerating when i felt the huge power lose.
    Answer all the questions so we can help you and read this........
    http://www.clubwrx.net/forums/genera...-question.html
    Resident Adviser @ WTF Tuning, LLC
    2002 FORESTER S
    1998 FORESTER S




  12. #11
    \_(ツ)_/ Rambo's Avatar
    Join Date
    Oct 2010
    Location
    Denial
    Posts
    4,813
    I Support ClubWRX
    In addition to Donkey's reading, this might help you learn more about the problem and get you started on troubleshooting: How to Troubleshoot Anything, and Ask for Help Later
    Isaac -- 2003 WRX sedan Stg II - Gave its life for mine 6/2013.
    2007 Outback 3.0R wagon
    Proud owner of a N.E.R.D, Member 1.3810-23

    He who shall be last, shall be sideways and smiling... - Jeremy Clarkson

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •